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VHDL Simulation과
Synthesis의 기초 실습

- Synopsys Tool을 중심으로 -

인천대학교 공과대학 전자공학과

System ASIC Design Lab.
지도교수 : 조 중 휘

jcho@asiclab.inchon.ac.kr

㈜ 본 강의교재에 대한 복제 및사용을 위하여는 저자의 허락을 받아 주십시오 .
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기초실습 순서및 개요

? 기초 실습-I
? 실습-1 : 1-Bit Full Adder Simulation

? Synopsys Simulation 환경 설정과 Simulation Tool 이해
? 실습-2 : 1-Bit Full Adder Synthesis

?Synopsys Synthesis 환경 설정과 Synthesis Tool 이해
? 실습-3 : 1-Bit Serial Adder 설계

?Synopsys Tool에 대한 종합적인 이해

? 실습-4 : 3-tap FIR Filter 설계
?조합논리회로 및 순서논리회로 설계에 대한 이해

? 실습-5 : Counter와 7-Segment Display 회로에 대한 설계
?계층적 설계에 대한 이해

? 기초 실습-II
? 실습-6 : Traffic Light Controller 설계

?Digital System에 대한 RTL 회로도 분석 능력

?VHDL 표현력 검증
?Synopsys Tool에 대한 이해와 사용
?Max+PlusII 동작에 대한 이해와 사용

? FPGA 구현을 통한 종합적인 이해와 응용력 향상

? 질의 및 응답
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Simulation을 위한 기본적인구성요소

? Synopsys VSS Simulator를위한기본구성

? VHDL compile : $ vhdlan {vhdl_source_file_name}
? Built-in Library

? standard, IEEE, synopsys, ASIC vendor, your own... 
? Working Library

? 설계된VHDL code를 compile 하여 생성된데이터(*.sim, *.mra)를 저장하는공간
? Simulation : $ vhdldbx
? 초기 setup file

? .synopsys_vss.setup

VHDL
Source code
(#vi exam.vhd)

Compile
(#vhdlan exam.vhd)

Built-in Library
(standard, IEEE, synopsys, ASIC vendor..)

Working
Library

exam.sim

exam.mra

Simulation
(#vhdldbx)

startup files
.synopsys_vss.setup
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VSS Simulator를 위한환경설정(1)

? .synopsys _vss.setup file의 설정에대한기본모형
? Working_Library_Name과 Working_Library_Directory는 User가 임의로정할수 있음

? Working_Library_Name 의미 : Compile시 저장되는장소로써 Symbolic Name
? Working_Library_Directory의미 : Working Library의 Directory Path

TIMEBASE = NS
WAVEFORM = waves

WORK > Working_Library_Name
Working_Library_Name : Working_Library_Directory

EDITCMD = xterm -geom 92x60 -T Synopsys-Editor -e vi

? 본실습에서는다음과같이구성한다.
? 각 User의 Home Directory에 sim_work directory를 Unix 명령어를사용하여생성한다.

$ mkdir ~/sim _work
? .synopsys _vss.setup file을 다음과같이설정한다 .

TIMEBASE = NS
WAVEFORM = waves

WORK > sim_work
sim_work : ~/sim_work

EDITCMD = xterm -geom 92x60 -T Synopsys-Editor -e vi
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VSS Simulator를 위한환경설정 (2)

? UNIX 환경에서사용하는 vi editor를 이용한 ~/.synopsys_vss.setup file 열기수행

? 필요로하는최소한의정보에대한입력
? Simulation 수행을위한 Default 시간단위에 대한 설정 : TIMEBASE
? Simulation 결과에대한 Default 표현방식에 대한 정의 : WAVEFORM
? Compile의 과정에서생성되는 여러 정보들의 기억공간에 대한 설정 : WORK

? 본 설계에서사용할예제는다음과같다 .

자신의계정에만든다 .
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실습-1 : Full Adder를 위한전체 Block 구조

? 설계사양에대한이해와분석
? 설계사양에대한분석과설계 대상체에대한 VHDL 표현

? Simulation을 위한적절한 Stimulus File 구성과 Test Bench 표현
? VHDL Simulation을통한검증

full adder
(fa.vhd)

stimulus
vectors

(vec.vhd)

A

B

C_in

C_out

Sum

test bench for Full adder
(tb_fa.vhd)
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실습-1 : Full Adder에 대한 Data flow 형태의 VHDL 설계

? Data Flow 형태의구현
library IEEE;
use IEEE.Std_logic_1164.all;
entity fa is
port (

A : in std_logic;
B : in std_logic;
C_in : in std_logic;
C_out: out std_logic;
Sum : out std_logic);

end fa;
architecture rtl of fa is
signal S0 : std_logic;

begin
S0 <= A xor B;
Sum <= S0 xor C_in;
C_out <= (A and B) or (S0 and C_in);

end rtl;

A
B

C_in
SUM

C_out

S0
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실습-1 : Stimulus Vector의 예시와이에대한 VHDL 설계

? 실습 1을위해사용자가설정한파형

? Stimulus Vector 생성부설계
library IEEE;
use IEEE.Std_logic_1164.all;
entity vec is

port (A, B, C_in : out std_logic);
end vec ;
--
architecture rtl of vec is
begin

process
begin

A <= ‘0’; B <= ‘0’; C_in <= ‘0’;
wait for 10 ns;
A <= ‘1’; B <= ‘0’; C_in <= ‘0’;
wait for 10 ns;
A <= ‘0’; B <= ‘1’; C_in <= ‘0’;
wait for 10 ns;
A <= ‘1’; B <= ‘1’; C_in <= ‘0’;
wait for 10 ns;
A <= ‘0’; B <= ‘0’; C_in <= ‘1’;
wait for 10 ns;
A <= ‘1’; B <= ‘0’; C_in <= ‘1’;
wait for 10 ns;
A <= ‘0’; B <= ‘1’; C_in <= ‘1’;
wait for 10 ns;
A <= ‘1’; B <= ‘1’; C_in <= ‘1’;
wait for 10 ns;

end process;
end rtl;

A

B

C_in

0 ns 20 ns 40 ns 60 ns 80 ns 100 ns
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실습-1 : Full Adder를 위한 Test Bench VHDL 설계

? Test Bench를위한 VHDL 설계
library IEEE;use IEEE.std_logic_1164.all;
entity tb_fa is
end tb_fa;
--
architecture rtl of tb_fa is
component fa

port (
A,B,C_in : in std_logic;
C_out,Sum: out std_logic);

end component;
component vec

port (
A,B,C_in : out std_logic);

end component;

-- 내부 Signal Assign
signal A, B, C_in : std_logic;
signal C_out, Sum : std_logic;

for U1 :  fa use entity work.fa(rtl);
for U2 :  vec use entity work.vec(rtl);

begin

-- U1, U2는 Component Label
-- 복잡한계층 구조를갖는설계를검증할때

-- 검증하고자하는하위계층을쉽게 알아볼수
-- 있도록이름을부여한다.

U1 : fa 
port map (

A=> A,B=> B,C_in => C_in,
C_out=> C_out,Sum=> Sum);

U2 : vec
port map (

A=> A,B=> B,C_in=> C_in);
end rtl;
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실습-1 : VHDL Code에 대한 Compile의 수행

? Code에대한 Compile의수행순서
? Design Tree에서하위 계층의VHDL 

Code부터 Compile을 수행한다. 

? 본 예제에서는 Unix Command에서
다음을수행한다. 
$ vhdlan fa.vhd
$ vhdlan vec.vhd

$ vhdlan tb_fa.vhd

? Compile 수행과정을표현하는
Window에대한예시는다음과같다.

fa.vhd vec.vhd

tb_fa.vhd
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실습-1 : Compile의수행에따라 생성되는 File 결과

? Compile을 Error 없이수행한경우 ~/sim _work Directory에생성되는여러정보의예
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실습-1 : Test Bench Compile 정보에 대한 Loading 수행시작

? Simulation Engine을사용하기위하여 Test Bench VHDL 표현에대한 Loading을
수행하기위하여다음과같은명령어를 사용한다.
? $ vhdldbx &를 수행하면다음과같은 Window가나타난다.

? Loading에따른 Window와각블럭에대한의미분석

Simulation 
수행에 따른 시간
단위에 대한 설정

Simulation을 하고자 하는
최상위 Configuration 

또는Entity_Architecture_n
ame을 선택 한다.

(여기서는 configuration)

선택된 Design

Working

Library 지정
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실습-1 : Test Bench Compile 정보에 대한 Loading 수행결과

? Loading에따라생성되는 Window와각블럭에대한의미분석

Command line

VHDL Top Model
Source code

typing
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실습-1 : VHDL Debugger의 Command에대한 정의

? 기본적인 Command 종류와의미분석(1)
? trace *

?현재의 source code에 있는
모든신호 출력

? cd label : cd U1
?원하는 sub-block으로 이동

? trace signal_name : trace s0
?원하는신호파형 출력

? cd ..
?상위 block으로 이동
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실습-1 : Simulation Engine에대한 수행

? 기본적인 Command 종류와의미분석(2)
? run 100

?Simulation Engine이 현재 시간부터 100 ns의 Simulation을 수행하도록하는명령어

? waveform scale에대한조정
? >tool-bar menu에서 View에해당하는 sub-menu 사용
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실습-1 : Simulation Waveform에 대한분석 과정

? Full Fit (전체보기)

? Zoom In (확대) 또는 Zoom Out (축소)
? Zoom Fit (지정된구간보기)
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실습-2 : VHDL 표현에 대한논리 합성의기본 개념

? 논리합성(Logic Synthesis)이란?
? Synthesis = Translation + Optimization + Mapping

.....
architecture rtl of fa is
  signal S0 : std_logic;
begin
  S0 <= A xor B;
  Sum <= S0 xor C_in;
  C_out <= (A and B) or (S0 and C_in);
.....

HDL Source code

Generic Boolean
(GTECH)

Target Technology

Translate into Boolean Representation

Optimize + Map

Synthesis
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Synopsys Synthesis Tool을위한 환경설정개념

? 환경설정을 File과개념정의
? Design Compiler의 Setup File : .synopsys _dc.setup
? Setup File의 위치에 따라미치는범위가다르게된다.

?Setup File이 없는 경우 : Synopsys Tool이 있는곳의 Default Setup File을 사용한다.
?자신의계정(account)에 있는경우 : 자신의계정에서작업하는모든곳에사용된다.
?특정한 Directory에있는 경우 : 이 특정한 Directory에 있는 Design Model에 사용된다.

~user

.synopsys_dc.setup

.synopsys_dc.setup

specific design

.synopsys_dc.setup

$SYNOPSYS/admin/setup

Standard
setup

User's General
Setup

User's Specific
Project (design) Setup
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Synopsys Synthesis Tool을위한 환경설정의예제

? 본실습에서사용하게되는 .synopsys _dc.setup File에대한예제는다음과같다. 
? 가정 : Target Library를 ALTERA FLEX10K로 한 경우이다.

? Target Library를 lsi_10k인 경우의설정에대한고찰
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실습-2 : Design Analyzer Window의설정

? Design Analysis를위한 Tool의 Loading을 Unix Command로써다음과같이수행한다.
? $ design_analyzer &에따라 다음과같은 Window가나타난다.

Up/Down
Hierarchy

View
Select

Informational 
Message Appear Here

Command 
menus

Current View
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실습-2 : Check Design Compiler Setup

? Design Analysis의 Command Menu에서 Setup의 Defaults..을선택.
? >Setup > Defaults로 선택하면다음과같은 Window가 Call된다 .
? 다음은 .synopsys_dc.setup File에서 설정된환경을 Loading 한 경우이다.

? 만일설정이되어있지않으면 여기서다음에해당하는 사항을설정하여야한다.
? Link Library
? Target Library
? Symbol Library
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실습-2 : Technology Library
? Link Library

? Optimization 하기 전에 Design Compiler에게 cells과 wireloads, 동작조건에대한정보를
제공하는 technology library.

? Target Library
? Synthesis 하는 동안 design compiler가 mapping을 수행하는 technology library.

? 일반적으로 link library와 target library는같은 technology library로설정한다.

Link
Library

HDL Code
Instantiated :
adders, NORs,
assorted gates

Gate Level Netlist

Design
Compiler

input

Design
Compiler

output

Target
Library

Optimized Netlist

Design mapped to gates from the Target Library
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실습-2 : Design Compiler로 File 읽기(1)

? Design Analysis의 Command Menu에서 File의 Read..를선택한다.
? >File > Read의 선택에의하여다음의 Window 가나타난다.
? File Name과 File Format을 설정하고, OK를 선택한다.

Reading Design File

Supports many different formats

db
edif
equation
lsi
mif
pla
st
tdl
verilog
vhdl
xnf

DescriptionFormat

Synopsys Internal Format
Electronics Design Interchange format
Synopsys Equation Format
LSI Logic Corporation Format
Mentor Intermediate Format
Berkeley (Expresso) PLA Format
Synopsys State Table Format
Tegas Design Language Format
Cadence Design Systems Inc. HDL
IEEE Standard VHDL
Xilinx Netlist Format
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실습-2 : Design Compiler로 File 읽기(2) 

? File Read를수행하는과정에다음과같은 Window가생성된다.

? Error가없는경우에오른쪽과같은

Window 생성된다.
? 해당되는VHDL Code에 따른

Symbol이 나타난다.
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실습-2 : HDL Files에 대한 Translate의 수행

? File Read의명령어와동일한의미로다음의명령어를사용하여 수행할수있다.
? Analyze와 Elaborate 명령

? Design Analysis의 Command Menu에서다음과같이명령어를선택한다.
? >File > Analyze로 선택한다.
? >File > Elaborate로선택한다.

선택
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실습-2 : HDL Files에 대한 Translate의 수행 결과

? Translate 수행결과
? 생성된 Symbol을 표시하는 Window는

다음과같다.

? 해당되는 Symbol의회로도보기
? 해당 Symbol을 Double Click 함 .
? Target Library와 설계자에 제시되는

설계 제약 조건을 고려하지 않은 논리
회로도가생성, 출력됨
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실습-2 : Optimization Constraints

? Optimization을수행할 Design Block을
선택하고, 다음의과정을수행한다.
? >Attributes > Optimization 

Constraints > Design Constraints에
의하여선택한다.

? 생성되는 Window는다음과같다.

선택

typing

? Optimization Constraints에대한설정
? Max.Area는 최종적으로 줄이고자 하는

Area의 목표 값으로 보편적으로 0으로
설정한다.

? 단위는 Vendor에 의해 제공되는 Target 
Technology Library 단위이다.
? e.g. : 2-input-NAND-gate, inverters, 

transistors, or square mils, etc.

? Design Rule Constraints에대한설정
? Max Fanout에 대한 설정

? Optimization 과 정 에 서 요 구 되 는
Fanout의 최대개수를지정한다.

? 설계에 따라 설계자의 다양한 선택이
요청되는항목이다.
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실습-2 : Optimization의 수행

? Optimization을수행할 Design Block을선택하고, 다음의과정을수행한다.
? >Tools > Design Optimization에 의하여선택한다.

? Design  Optimization Window에서 “OK”를선택한다.
? Optimization의 과정을표시하는 Window 가나타나면서수행된다.

선택
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실습-2 : Optimization의 수행에따른회로도 출력

? 각 Symbol에대하여 Target Library를사용한설계도면의생성
? 각 Symbol을 Double Click 하여 선택하면다음과같은논리회로도도면이생성된다.
? VHDL Modeling 형태에 따라다르다.

?Behavioral Modeling : 논리 회로도출력

?Structural Modeling : 해당 Component로 연결되는 Symbol 구성도출력
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실습-2 : Optimization의 수행에따른 Report 분석(1)

? 사용된 Cell에따른면적정보, Delay 정보및 Critical Path 정보등을분석한다.
? Command Menu에서 >Analysis>Report를 선택하면다음과같은 Window 가설정된다.
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실습-2 : Optimization의 수행에따른 Report 분석(2)

? 사용된 Area에대한 Report File의출력
? 앞의 Window에서Area를 선택한다.

? Delay 정보에대한 Report File의출력
? 앞의 Window에서Timing을선택한다.
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실습-2 : Optimization의 수행에따른 Critical Path에 대한 분석

? 회로도의 Path 중에서 Timing Delay가가장크게분석되는 Path의설정을한다.
? Command Menu에서 >Analysis>Highlight>Critical Path를 선택하면 다음 Window 가

나타난다.
? 도면에서굵은선으로표시된 Path가 Critical Path이다.
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실습-2 : 설계 결과저장

? Synthesis된결과를저장
? ALTERA Library를 사용하는경우 edif형식으로저장

? Recommendation : Always use the save ALL Designs in Hierarchy option.

저장할 file 이름

저장할 file 형식 설정

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-34

실습-3 : 직렬 가산기의핵심 블럭에대한 설계

? 실습1에서설계한 Full Adder를이용하여 N-Bit 직렬가산기에요구되는 핵심블럭에
대한 VHDL 표현을행한다.

? 직렬로입력되는두개의값을 더하여직렬로출력하는 구조이다.
? carry를저장하기위하여 1-Bit의 Flip-Flop이 요구된다. 

Full Adder
(fa.vhd)

c_in

a

b

sum

c_out

carry_in carry_out

Bit Serial Adder
(bit_add.vhd)

D F/F
(reg1.vhd)

reset clock

a

b

sum
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실습-3 : 직렬 가산기블럭에 대한 VHDL 설계

? 1-Bit Flip-Flop에대한 VHDL 표현
library IEEE;use IEEE.std_logic_1164.all;
entity reg1 is
port ( reset, clock: in std_logic;

d_in : in std_logic;
d_out : out std_logic);

end reg1;
architecture rtl of reg1 is
begin
process ( reset, clock, d_in )
begin
if reset = '0' then
d_out <= '0';

elsif clock = '0' and clock'event then
d_out <= d_in;

end if;
end process;

end rtl;

? 직렬가산기에대한 VHDL 표현
library IEEE; use IEEE.std_logic_1164.all;

entity bit_add is
port ( a, b, reset, clock : in std_logic;

sum : out std_logic);
end bit_add;
architecture rtl of bit_add is

component f a
port ( a, b, c_in : in std_logic;

sum, c_out : out std_logic);
end component;
component reg1

port ( reset, clock, d_in : in std_logic;
d_out : out std_logic);

end component;
for u0 : f a use entity work.f a(rtla);

for u1 : reg1 use entity work.reg1(rtl);
signal carry_in, carry_out : std_logic;

begin

u0 : f a port map (a, b, carry_in, sum, carry_out);
u1 : reg1 port map (reset, clock, carry_out, carry_in);

end rtl;

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-36

실습-3 : 직렬가산기 블럭에대한 File Read

? 실습1과같이합성하고자하는 3가지 VHDL Code에대하여 File Read를수행한다.
? 계층적설계의경우하위 블럭에대응하는 VHDL Code부터 File Read를 수행한다. 
? >File>Read>fa.vhd
? >File>Read>reg1.vhd
? >File>Read>bit_add.vhd

fa.vhd reg1.vhd

bit_add.vhd
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실습-3 : Clock 주기에 대한설정

? Clock에 attributes를주는경우
? Design Analyzer에서 clock에 대응하는신호를선택하여원하는동작속도를지정한다.
? Design Analysis의 Command Menu에서 Attributes의 Clock, Specify를선택한다.

? >Attributes > Clock > Specify에 의하여지정한다.

선택

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-38

실습-3 : Design Constraint에 대한설정

? Optimization을수행하기전에 Optimization 조건과 Design Rule에대하여설정한다.
? 계층적설계인경우최상위 symbol을 선택한다음수행한다.
? >Attributes > Optimization Constraints > Design Constraints 에 의하여선택된다.

typing

선택
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실습-3 : Optimization에 대한조건설정과 수행

? 먼저 Optimization을수행할 Design Block을선택하고,  다음과정을수행한다.
? >Tools > Design Optimization에 의하여선택한다.

? Design  Optimization Window에서 “OK”를선택한다.
? Optimization의 과정을표시하는 Window 가나타나면서수행된다.

? 사용된 Cell 정보및 Delay 정보등의출력을분석하여보자.
? Report File의 생성과 분석

선택

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-40

실습-3 : 계층적 설계도면의 1-Level로의변환 과정 (선택과정)

? 계층적으로합성된경우 1-Level로변환하려면, 변환하려는 부분을왼쪽마우스로
영역을선택한후다음과같은 일을수행한다.
? >Edit > Ungroup에 의하여선택한다.

? 1-Level 논리회로도에대한표현
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실습-4 : 3-Tap FIR Filter에 대한 RTL 회로

? 3-Tap FIR Filter에대한사양분석에따라 다음과같은 RTL 회로를 생성한다.
? VHDL 표현을행하고, Simulation과 Synthesis를수행한다.

reset

clock

ADDER

"01000"

8 8

8

13 13 13

10

fir_in

fir_out

sequential
Logic

combinational
Logic

8

10

5
"00100"

5
"00010"

5

Reg. Reg.
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실습-4 : 3-Tap FIR Filter에 대한 VHDL 표현

library IEEE; use IEEE.std_logic_1164.all;
use IEEE.std_logic_signed.all;
entity fir is
port ( fir_in : in std_logic_vector(7 downto 0);   

clock : in std_logic;
reset : in std_logic;
fir_out : out std_logic_vector(9 downto 0));

end fir;
--
architecture rtl of fir is 
signal t_1, t_2  : std_logic_vector(7 downto 0);

-- filter 계수에대한 선언
constant a1 : std_logic_vector(4 downto 0) := 

"01000";
constant a2 : std_logic_vector(4 downto 0) := 

"00100";
constant a3 : std_logic_vector(4 downto 0) :=

"00010";
begin 

--filter register에 대한표현

process(clock,reset) begin    
if reset = '0' then

t_1 <= (others => '0');
t_2 <= (others => '0');

elsif clock'event and clock = '0' then
t_1 <= fir_in;
t_2 <= t_1;    

end if;  
end process;  

--filter 값 계산을위한산술 연산블럭의표현

process(fir_in, t_1, t_2)
variable b_0, b_1, b_2, tmp :

std_logic_vector(12 downto 0);   
begin

b_0 := a1 * fir_in;    b_1 := a2 * t_1;
b_2 := a3 * t_2;    tmp := b_0 + b_1 + b_2;
fir_out <= tmp(12 downto 3);

end process;
end rtl;
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실습-4 : FIR Filter의 검증을 위한 Test Bench VHDL 표현

library IEEE; use IEEE.std_logic_1164.all;
entity tb_fir is end tb_fir;
--
architecture rtl of tb_fir is
--
component fir
port ( fir_in   : in std_logic_vector(7 downto 0);  

clock   : in std_logic;
reset   : in std_logic;

fir_out : out std_logic_vector(9 downto 0));
end component;

--
for u0: fir use entity work.fir(rtl);

--
signal fir_in   : std_logic_vector(7 downto 0);
signal clock, reset  : std_logic := '0';
signal fir_out  : std_logic_vector(9 downto 0);

--
begin
u0: fir port map ( fir_in, clock, reset, fir_out);  

clock <= not clock after 20 ns;
--
reset <= '1' after 10 ns;   

--
process
begin
fir_in <= "00010000", "00101110" after 100 ns,

"00110001" after 200 ns,
"01000111" after 300 ns,
"00001010" after 400 ns,
"00011100" after 500 ns,
"00100001" after 600 ns,
"00000111" after 700 ns;

wait for 800 ns;
end process;

end rtl;
--
configuration conf of tb_fir is  
for rtl end for;

end conf;

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-44

실습-4 : Synopsys Simulator를 이용한 VHDL 검증

? Waveform의생성에따른설계사양과의기능 일치성분석
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실습-4 : Synopsys Synthesis Tool을 이용한회로도합성

? 논리회로도합성과설계조건에 따른만족성분석
? 설계도면분석, 각종 Report File에 대한분석

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-46

실습-5 : Synthesis Tool 실습을위한예제의 동작사양

? 목적
? Simulation Tool에대한요약과회로

합성에대한단계별설명과실습
? 설계사양
? 10 진 Counter의설계

? 10 진 Counter의 출력 값 표시를
위한 Seven-Segment 드라이버
설계

? 10진 Counter

? Segment

COUNTER

7-SEG
Driver

f

c

g

e

d

a

b

CLK

RESET

SEG_OUT

RESE
T

CLK CNT_OU
T(n)

CNT_OUT(n+1)

1 X X “0000”

0 ? “1001” “0000”

0 ? “1001” 이외
값

CNT_OUT(n) +
‘1’

CNT_OUT SEG_OUT
“0000” "1111110"
“0001” "1100000"
“0010” "1011011"
“0011” "1110011"
“0100” "1100101"
“0101” "0110111"
“0110” "0111111"
“0111” "1100110"
“1000” "1111111"
“1001” "1110111”
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실습-5 : 예제의 Behavioral Level VHDL 설계

? Counter의 VHDL 설계
library IEEE;  use IEEE.Std_logic_1164.all;

use IEEE.Std_logic_unsigned."+";
entity Counter is

port (   RESET : in std_logic;
Clk  : in std_logic;
CNT_out : out std_logic_vector(3 downto 0));

end Counter;
architecture Counter_Arch of Counter is

signal CNT : std_logic_vector(3 downto 0);
begin

process(RESET, CLK)
begin

if RESET = '1' then
-- same expression of CNT <= "0000";
CNT <= (others => '0');

elsif Clk'event and Clk = '1' then
if CNT = "1001" then
CNT <= (others => '0');

else
CNT <= CNT + '1';

end if;
end if;

end process;
CNT_out <= CNT;

end Counter_Arch;

? Segment의 VHDL 설계
library IEEE; use IEEE.Std_logic_1164.all;
entity Segment is

port ( Seg_IN : in std_logic_vector(3downto 0);
Seg_OUT : out std_logic_vector(6downto 0));

end Segment;
architecture Segment_Arch of Segment is
begin

process(Seg_IN)
begin

case Seg_IN is 
when "0000" => Seg_OUT <= "1111110";
when "0001" => Seg_OUT <= "1100000";
when "0010" => Seg_OUT <= "1011011";
when "0011" => Seg_OUT <= "1110011";
when "0100" => Seg_OUT <= "1100101";
when "0101" => Seg_OUT <= "0110111";
when "0110" => Seg_OUT <= "0111111";
when "0111" => Seg_OUT <= "1100110";
when "1000" => Seg_OUT <= "1111111";
when "1001" => Seg_OUT <= "1110111";
when others => Seg_OUT <= "0000000";
end case;

end process;
end Segment_Arch;
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실습-5 : 예제의 Structural Level 및 Test Bench VHDL 설계

? CNT_SEG의 VHDL 설계
library ieee; use ieee.std_logic_1164.all;
entity CNT_SEG is
port ( RESET : in std_logic;

Clk : in std_logic;
Seg_out : out std_logic_vector(6 downto0));

end CNT_SEG;
architecture CNT_SEG_Arch of CNT_SEG is
component Counter
port ( RESET : in std_logic;

Clk : in std_logic;
CNT_out : out std_logic_vector(3 downto0));

end component;
component Segment
port ( Seg_IN : in std_logic_vector(3 downto0);

Seg_OUT : out std_logic_vector(6 downto0));
end component;
signal CNT_out : std_logic_vector(3 downto0);
for CNT : Counter

use entity work.Counter(Counter_Arch);
for Seg : Segment

use entity work.Segment(Segment_Arch);
begin
CNT : Counter port map

(RESET=> RESET,Clk=> Clk,CNT_out=> CNT_out);
Seg : Segment port map

(Seg_IN=> CNT_out,Seg_OUT=> Seg_OUT);
end CNT_SEG_Arch;
configuration CNT_SEG_C of CNT_SEG is
for CNT_SEG_Arch
end for;

end CNT_SEG_C;

? Test-Bench를위한 VHDL 설계
library IEEE; use IEEE.Std_logic_1164.all;
entity TB_CNT_SEG is 
end TB_CNT_SEG;
--
architecture TB_CNT_SEG_Arch of TB_CNT_SEG is
component CNT_SEG

port ( RESET : in std_logic;
Clk : in std_logic;
Seg_out : out std_logic_vector(6 downto 0));

end component;
signal RESET : std_logic := '1' ;
signal Clk : std_logic := '1' ;
signal Seg_out : std_logic_vector(6 downto 0);

begin
RESET <= '0' after 5 ns;
Clk <= not Clk after 10 ns;
Counter : CNT_SEG port map ( 

RESET => RESET,
Clk => Clk,
Seg_out => Seg_out);

end TB_CNT_SEG_Arch;
--
configuration TB_CNT_SEG_C of TB_CNT_SEG is
for TB_CNT_SEG_Arch
end for;

end TB_CNT_SEG_C;
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실습-5 : VSS Simulator를 사용한기능 검증

? 각 VHDL Source Code에대하여 Analysis를수행한다. 
$ vhdlan Counter.vhd
$ vhdlan Segment.vhd
$ vhdlan CNT_SEG.vhd
$ vhdlan TB_CNT_SEG.vhd
? File_Name.scr에위의내용을저장하고, Script File을수행한다. (예제 : Comp.scr)

? Debugging Tool의 Loading과 Simulation Library 및 Design Model을선택한다.
$ vhdldbx &
? 예제에서의 Design Model은 SIM_WORK.TB_CNT_SEG_C이다.

? Waveform 생성단계
? 다음명령어를하나씩수행하면 Waveform과값이생성된다. 

trace *
trace /TB_CNT_SEG/Counter/CNT_out
run 300

? Script File을이용하는경우
?File_Name.scr에위의내용을저장한다.
?Command 명령어에서 include Comp.scr을실행한다.
?Waveform과값이생성된다.

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-50

실습-5 : Design Analyzer Window의설정

? Design Analysis를위한 Tool의 Loading을수행한다.
$ design_analyzer & 
? 다음과같은 Window가 Call된다.
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실습-5 : VHDL File의 Read 수행

? VHDL Source File을 Read 하여내부데이터형태로저장한다.
? Window 상에서 File -> Read를선택하면 다음과같은 Window가 Call된다.
? Window상에서 Bottom-Up 즉, 하위부터 VHDL Code를 Read 한다.
? Counter.vhd
? Segment.vhd
? CNT_SEG.vhd

Conter Segment

CNT_SEG

계층구조
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실습-5 : Clock 신호에 대한지정

? Clock 신호와주기를결정한다.

1. CNT_SEG를
Double클릭한다 .

2. Clk핀을 클릭한다 .
3. Attribute -> clock -> 
Specify를클릭하고다음
그림과같이설정하고
Apply를 클릭한다 .



27

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-53

실습-5 : Design Constraint의 설정

? Optimization 조건과 Design Rule을설정한다.
? 계층적설계인경우최상위 symbol을선택한다음수행한다.
? Attributes -> Optimization Constraints ->Design Constraints 에의하여선택된다.

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-54

실습-5 : 논리 회로도의생성

? 논리회로를생성하며, 관찰한다.
? 다음은설계예제의최상위 Block인 CNT_SEG의회로도이다.
? 하위 Level의논리회로를보기위해서는 회로상에서보고자 하는 Component 

Unit을 Double Click한다. 
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실습-5 : Physical Design을 위한 EDIF File 생성

? EDIF File 생성
? File -> Save as에의하여 File Format을 EDIF로 선택

? File Name을본예제의경우 CNT_SEG.edf 로 설정하여다음과같이 입력한다.

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-56

실습-5 : FPGA Compiler에 의한 Physical Design

? 본예제에서는 MAX+PLUSII를사용함.
? $ maxplus2&를실행한다

? File -> Project -> Name 에 서
CNT_SEG.edf 를 선택한다.

? MAX+PLUSII -> Compile를클릭한다.
? Interface -> Edif Netlist Reader 

Settings에서 Synopsys 를선택한다.
? Interface -> VHDL Netlist Writer 를

클릭한다 . 출력 VHDL File은 Project 
Name.vho로 출력되며 Timing 정보를
이용한검증을위해사용된다.

? Assign -> Device 를선택한다.
? Family는 FLEX8000을선택한다.
? Devices 는 예 제 에 서 는

EPF8282LC84-3을선택한다.
? Compiler Window에서 Start를클릭한다.
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실습-5 : 합성된 회로에대한 Timing Simulation

? VHDL Source Code에의한 Function Simulation Waveform

? FPGA Compiler에의하여생성된 Timing 정보를갖는 VHDL File에대한 Timing 
Simulation Waveform

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-58

실습-6 : Traffic Light Controller의 설계사양 및분석

? Word Description 형태의설계사양에대한분석
? Highway와 Farm road가 교차하는 지점에 대한신호등의 제어기 설계

? Farm Road에 차가 대기하고있음은 Car 검출기에 의하여 검출됨
? 초기적으로 Highway 방향으로 Green 신호를 출력하는데 TL 시간이 경과하면 Car 검출 신호를

조사하여 검출되면 Highway Yellow Mode로 전환하나, 검출되지 않으면 유지한다.
? Highway Yellow Mode 전환 후에는 TS 시간이 경과하면, Highway Red Mode로 전환한다.
? Farm Road Green Mode에서는 TL 시간이 경과하면 Car 검출 여부에 관계없이 Farm Road Yellow 

Mode 전환하며, Car 가 검출되지 않으면 TL 시간 도달 전일지라도 Farm Road Yellow Mode로
전환한다.

? Farm Road Yellow Mode에서는 TS 시간이경과하면 Highway Green Mode로 전환한다.
? TL 시간은 (16개 CLK)*(CLK 주기 30초)로 하며, TS 시간은 (1개 CLK)*(CLK 주기 30초)로 한다.

Highway

HLFL

Farmroad

C

HL

Highway

FL
C
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실습-6 : Traffic Light Controller의 사양분석과 Block 설계

? 설계사양분석으로 Block Diagram의추출
? 여러 개의 Module로 개념에 따라 분할 : Modular Design

? I/O Pin에 대한 추출과 정의

short time/
long time
counter

Next State
Output
Logic

State
Register

Car
Sensor

Light
Decoders

Reset

C(async)

Clk

C(sync)

Reset

Clk

ST

Encoded

Light

Signals

controller fsm

TS TL

F

H

3

3

2
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실습-6 : Traffic Light Controller의 기능및 구조설계

? Car Sensor 기능및구조설계
? 외부입력 신호인 Car-Async 신호를

CLK에 동기 시켜내부에서사용하기
위한회로

? Short Time 및 Long Time 신호의
생성을 위한 4-비트 Counter 기능 및
구조설계
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실습-6 : Traffic Light Controller 기능및 구조설계

? Light Decoders 기능및구조설계
? 4가지상태에따른 분류

? High-Way 방향과 Farm-Road 방향에
대한신호등의색깔을 4가지상태에
따라결정하는 Decoder 회로
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0
1
0
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1
0
0

H0(F0)

0
0
1
1

HY(FY)

0
1
0

HR(FR)
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Not Allowed

Light

Green
Yellow

Red

? Traffic Light State Controller 기능설계
? 4가지상태의설정과이들 사이의천이를

나타내는 State Table과 State Diagram 
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실습-6 : Traffic Light Controller의 VHDL 설계

--Timer 회로를 counter를 이용하여표현

-- HG에서의 count 값 변화에 유의할 것

process (RESET, CLK) begin
if RESET=‘0’then

COUNT <= “0000”;
elsif CLK = '1' and CLK'event then

if ST = '1' then
COUNT <= "0000";

elsif C_STATE=S0 and COUNT=“1111” then
COUNT <= COUNT; --NULL 구문과동일

else
COUNT <= COUNT + '1';

end if;
end if;

end process;
--Long time, short time 신호에 대한 생성
TS<='1' when COUNT="0000" else '0';
TL<='1' when COUNT="1111" else '0'; 

--High-way 신호등 ON/OFF 신호 생성

HG<='1' when H=GREEN  else '0';
HY<='1' when H=YELLOW else '0';
HR<='1' when H=RED else '0';

? VHDL을이용한표현
library IEEE; use IEEE.std_logic_1164.ALL;
use IEEE.std_logic_unsigned."+";
entity TRAFFIC is
port (RESET, CLK, C_ASYNC : in  std_logic;

HG, HY, HR, FG, FY, FR : out std_logic);
end TRAFFIC;
architecture RTL of TRAFFIC is

type STATE is (S0, S1, S2, S3);
type LIGHT is (GREEN, YELLOW, RED);
signal C_STATE, N_STATE : STATE;
signal H, F : LIGHT;
signal C_SYNC, ST, TS, TL : std_logic;
signal COUNT:std_logic_vector(3 downto 0);

begin
A: block begin
process (RESET, CLK) begin

if RESET = '0' then
C <= '0';

elsif CLK = '1' and CLK'event then
C <= C_ASYNC;

end if;
end process;
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실습-6 : Traffic Light Controller의 VHDL 설계

--Farm road의 신호등 ON/OFF 신호 생성

FG<='1' when F=GREEN else '0';
FY<='1' when F=YELLOW else '0';
FR<='1' when F=RED else '0';

end block;
--상태 기억 변수의 설정에 대한 표현

B: block begin
process (RESET, CLK) begin

if RESET = '0' then
C_STATE <= S0;

elsif CLK = '1' and CLK'event then
C_STATE <= N_STATE;

end if;
end process;
--다음 상태 결정과 timer 제어신호 결정
process (C_STATE, TS, TL, C_SYNC) begin
case C_STATE is

when S0 => H <= GREEN; F <= RED;
if (TL = '1') and (C_SYNC = '1') then
N_STATE <= S1; ST <= '1';

else
N_STATE <= S0; ST <= '0';

end if; 

when S1 => H <= YELLOW; F <= RED;

if TS = '1' then
N_STATE <= S2; ST <= '1';

else
N_STATE <= S1; ST <= '0';

end if;     

when S2 => H <= RED; F <= GREEN;
if (TL = '1') or (C_SYNC = '0') then

N_STATE <= S3; ST <= '1';
else

N_STATE <= S2; ST <= '0';

end if;
when S3 => H <= RED; F <= YELLOW;

if TS = '1' then
N_STATE <= S0; ST <= '1';

else
N_STATE <= S3; ST <= '0';

end if;

end case;
end process;

end block;
end RTL;
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실습-6 : Traffic Light Controller Test Bench 설계

? Simulation을위한 Test Bench 표현
? Stimulus Vector 생성부

? Traffic Light Controller 본체부
library IEEE; use IEEE.std_logic_1164.ALL;
--Empty entity에대한 표현
entity TB_TRAFFIC is end TB_TRAFFIC;
architecture RTL of TB_TRAFFIC is

--Test 할 component에대한 선언
component TRAFFIC

port (RESET,CLK,C_AYNC : in std_logic;
HG,HY,HR,FG,FY,FR : out std_logic);

end component;
--연결함에 요구되는 신호에 대한 선언
signal RESET : std_logic;
signal CLK : std_logic := '0';
signal C_ASYNC : std_logic;
signal HG,HY,HR,FG,FY,FR : std_logic;
--component에 대한 configuration 선언
for U0 : TRAFFIC use entity work.TRAFFIC(RTL);

begin

--주기적 신호에 대한 vector 생성 구문

CLK <= not CLK after 15 sec;
--초기화 신호에 대한 vector 생성 구문

RESET <= '0', '1' after 1 sec;
--Random 신호에 대한 vector 생성 구문

process begin
C_ASYNC <= '0';
wait for 10 min;
C_ASYNC <= '1';
wait for 5 min; 
C_ASYNC <= '0';
wait for 5 min;
C_ASYNC <= '1';
wait for 5 min; 

end process;

--동작 회로의 Pin 정보와 Wire 정보의연결

U0 : TRAFFIC
port map (RESET, CLK, C_ASYNC, HG, HY,

HR, FG, FY, FR); 
end RTL;
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실습-6 : Traffic Light Controller VHDL 표현에대한 검증
? Test Bench에대한 Synopsys Simulation에따른파형
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실습-6 : Traffic Light Controller의 계층적논리 합성

? Script File에대한예
read -f vhdl traffic.vhd

group -hdl_block A 
group -hdl_block B

create_clockclk
max_delay 0 -to all_outputs()
compile -map_effort high
create_schematic
write -f db

write -f edif -hierarchy -o traffic.edf

? 2개의 Sub-Block으로구성됨을확인
? 회로도의 Block에 대한 Label
? VHDL Block 구문의 Label 일치
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실습-6 : Traffic Light Controller의 1-Level 논리합성

? 1-Level 논리회로구성을위한 Script File과논리합성결과
read -f vhdl traffic.vhd
create_clockclk
max_delay 0 -to all_outputs()
compile -map_effort high
create_schematic
write -f db
write -f edif -hierarchy -o traffic.edf

? 7개의 Flip-Flop과 Random Logic으로구성됨을확인

Univ. of Inchon   System ASIC Design Lab. SynopsysVHDL 기초 실습 NO-68

실습-6 : Traffic Light Controller VHDL의 FPGA 구현

? Synthesis된결과를저장 ( 실습 NO-33과동일)
? ALTERA Library를 사용한 FPGA 환경을 위해 edif형식으로저장
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? 실습자개인 directory에 MAX 라는 Sub-directory를만든다
? 생성된 traffic.edf 화일을 MAX directory로옮긴다

? MAX directory에서 Max+plus를실행한다. 
? 실행명령어 : max2win& 

? Project의설정
? File -> Project -> Name 에서 traffic.edf를선택

? Device 설정
? 설계 사양에 알맞은 Device를 선택한다.

?이번 설계실습에서는 FLEX 8000 시리즈 중
EPF8282LC84-3을 사용하기로 한다

? Assign -> Device 에서 EPF8282LC84-3 선택

실습-6 : Traffic Light Controller VHDL의 FPGA 구현

실습자의 MAX 
directory로

이동

선택되어 있으면 버튼을
해제한다
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실습-6 : Traffic Light Controller VHDL의 FPGA 구현

? 오른쪽버튼중 Device Options 를 선택

? Configuration 설정은 Active Parallel Up 선택 ? Add15,16,17을 두 번씩 클릭하여 선택을 해제
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실습-6 : Traffic Light Controller VHDL의 FPGA 구현

? Compiler 실행

? Max+plus II -> Compiler 선택 후
? Processing -> Preserve All Node Name Synonyms 선택

( 1 bit 이상의 다수의 Node를 같은 Name으로 지정하게한다)
? Interfaces -> Edif Netlist Reader Settings 선택

? Interfaces -> VHDL Netlist Writer Settings 선택

? Interfaces -> VHDL Netlist Writer 선택
(실제 Gate Delay를 고려한 Timing
Simulation을 위한 .vho 파일생성)

Vendor를 Synopsys 선택

선택되어 있는지 확인
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실습-6 : Traffic Light Controller VHDL의 FPGA 구현

? Start 버튼을 눌러 Compiler를 실행한다

? error가없음을확인하고빠져나온다

?만일 error 가 체크되면해당 내용을살펴본후수정하도록한다

? rpt 파일을 두번 클릭하여 compile 결과와 그 외 여러가지내용을확인해보도록한다
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실습-6 : Traffic Light Controller VHDL의 FPGA 구현

? Pin Re-Fitting 
? rpt 파일 내용을통해, compile 후 핀 배치가이루어짐을알수 있다
? 이번설계에서는이미구성된 FPGA 보드를통해구현하여야하므로, 핀배치를재구성할

필요가있다
? Max+plus II -> Compiler 선택 후, Assign -> Back-Annotate Project 를 선택

? Hierarchy Display 를 선택 -> acf 파일을두번 클릭하여활성화시킨다
? FPGA Chip 내 의 여러 가지핀 정보들이나와 있음을알수 있다

? 자세히확인하여, acf 파일내에서 In, Out port의 핀에관한정의 부분을찾는다

check후 OK를 누른다 NO 를 선택(주의할것)
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실습-6 : Traffic Light Controller VHDL의 FPGA 구현

? 해당부분을아래와같이 수정한후, 
저장한다

| C_ASYNC :    INPUT_PIN = 73
| CLK :          INPUT_PIN = 12;
| RESET :          INPUT_PIN = 31;
| FG :          OUTPUT_PIN = 30;
| FR :          OUTPUT_PIN = 56;
| FY :          OUTPUT_PIN = 25;
| HG :          OUTPUT_PIN = 24;
| HR :          OUTPUT_PIN = 28;
| HY :          OUTPUT_PIN = 16;

? 다시한번 compiler 를 실행시킨후 , 
Max+plus II를 종료한다

? MAX directory 내의 traffic.hex 파일을
27C256 ROM에 Download하여구성된
FPGA

테스트보드를통하여 동작여부를
확인한다.

C_ASYNC

High Way

Farm Road

256ROM FPGA
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실습-6 : FPGA를이용한 Prototyping과 검증

? Traffic Light Controller에대하여 FPGA를 이용한검증 Board의예
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