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 Welcome to NetlistViewer Standalone 

Welcome to NetlistViewer Standalone 
The NetlistViewer tool displays the contents of the design as a schematic, making it easier for you to debug your design. Use this tool 
to view nets, ports, and instances and to trace signals. Used with PinEditor, ChipEditor, or Timer, NetlistViewer assists you in meeting 
area and timing goals by helping you identify critical paths. 

You can start NetlistViewer only after the design has been compiled.  

Note:  This version of NetlistViewer supports only the MX, SX-A, eX, RTSX, and RTSX-S families. If you are designing for the 
ProASIC3E, ProASIC3, ProASIC PLUS, Axcelerator, and ProASIC families, use NetlistViewer in MultiView Navigator. See 
the MultiView Navigator User’s Guide for more information. 

Starting NetlistViewer Standalone 
NetlistViewer is available from Designer's main window. You can only start it after your design is compiled. To start NetlistViewer 
from Designer, either click the NetlistViewer icon in the Designer Design Flow window, or from the Tools menu, choose 
NetlistViewer. NetlistViewer reads your netlist design and generates a clearly-laid out schematic 

NetlistViewer reads your netlist design and generates a clearly-laid out schematic view, as shown in the figure below. 

 

  

NetlistViewer Standalone 
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Components of NetlistViewer Standalone  

Components of NetlistViewer Standalone 
NetlistViewer consists of three windows: 

• Schematic  

• Hierarchy View 

• Search Tool 

NetlistViewer also contains a menu bar, toolbar, and status bar. 
  

 

NetlistViewer with All Windows Open 
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 Schematic Window 

Schematic Window 
The Schematic window displays a graphical representation of the netlist. It automatically opens when you start NetlistViewer. 

  

Schematic Window 
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Search Tool Window  

Search Tool Window 
Use the Search Tool window to search for instances, nets, and ports.  

To open the Search Tool window, from the View menu, choose Search Tool. The Search Tool window opens to the right of the 
Schematic window. This window is sizable and dockable. 

 

Search Tool Window 
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 Hierarchy Window 

Hierarchy Window 
The Hierarchy window provides easy navigation through the design hierarchy and gives a compact hierarchy overview. When you 
select an instance in this window, it appears highlighted in the NetlistViewer window.  To view the Hierarchy window in 
NetlistViewer Standalone, from the View menu, choose Hierarchy. The Hierarchy View window opens. This window is sizable and 
dockable. 

 

Hierarchy Window 

Navigating through Your Netlist 
You can navigate in the logical view of the design in two directions: vertically and horizontally. 

Vertical Navigation 
Navigate vertically through your hierarchical design by using the Push, Pop, and Top commands. These commands are available 
from the Edit menu, the right-click menu, and the toolbar. You can also use the following keyboard shortcuts:  

• CTRL-P for Push 

• CTRL-O for Pop  

• CTRL-T for Top 

To go one level deeper in a design: 
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Selecting Objects  

1. Select an instance. 

2. From the Edit menu, choose Push, or from the right-click menu, choose Push instance <name>. 

To go one level higher in a design, from the Edit menu, choose Pop. To go to the top level, from the Edit menu, choose Top. 

Horizontal Navigation 
When large designs do not fit in the Schematic window, NetlistViewer splits the design into multiple pages. Page splitting enables you 
to quickly compute and display the schematic.  

To navigate to the next page in a design, from the View menu, choose Go to Next Page, or click the Next Page button in the toolbar. 

To navigate to the previous page, from the View menu, choose Go to Previous Page, or click the Previous Page button in the toolbar. 

To navigate to the first page, from the View menu, choose Go to First Page, or click the First Page toolbar button.  

To navigate to the last page, from the View menu, choose Go to Last Page, or click the Last Page toolbar button. 

Following Nets 
Following a net might take you to another page or another level in your design. Following nets is useful when your design is split into 
several pages or if it includes some hierarchical logic. To follow a net, click a net that continues before or after the page being viewed. 
Nets that continue on other pages are terminated by a page connector symbol (>). Note that a net can continue on many pages. 

 

Indicates the net ends on another page 

 

Indicates the net begins on another page 

   

The illustrations below show two pages including net data_6. On both pages, the net ends with the page connector symbol (>), 
indicating the net continues on another page. As stated earlier, the net can continue on many pages. 

           

Symbols for a Continuing Net 

Selecting Objects 
Before you can highlight an object, you must first select it. To select an object, left-click it. 

To select a group of objects in NetlistViewer, press and hold down SHIFT, and then click each object to select.  

To unselect specific selected objects, press and hold down SHIFT, and then click a selected object to unselect it. You can also hold 
down the left mouse button and drag a rectangle toward the bottom-right corner. Release the mouse button when all items you want to 
unselect are included in the rectangle. 

To unselect all selected objects, click a clear spot in the Schematic window. 
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 Highlighting Objects 

Highlighting Objects 
Highlight objects or groups of objects for easy reference. By default, highlighted objects are displayed in red in NetlistViewer.  

To highlight an object: 

1. Select the object in the NetlistViewer. 

2. From the Edit menu, choose Highlight, or click the Highlight button in the toolbar. The object changes color.  

 

Highlighted Object 

To highlight a group of objects: 

1. Press and hold down the SHIFT key, and then click each object you want to highlight. 

2. From the Edit menu, choose Highlight, or click the Highlight toolbar button. 
This can be useful for tracing a net. 

 

Highlighting Groups of Objects 

To unhighlight an object or group of objects: 

1. Select the object(s) to highlight.  

2. From the Edit menu, choose Un-Highlight, or click the Unhighlight toolbar button. 

To unhighlight all highlighted objects, from the Edit menu, choose Clear Highlight, or click the Clear Highlight toolbar button. 

Highlight Append 
The Highlight Append command highlights the currently selected object and adds it to the highlighted group, which includes the last 
highlighted object.  

To highlight and append an object: 

1. Select the object in the NetlistViewer. 

2. From the Edit menu, choose Highlight Append, or click the Highlight Append button in the toolbar. The object changes color. 
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Searching for Objects  

Searching for Objects 
Searching for objects can shorten your debug time, since you can locate an instance, net, or port in a complex design without pushing, 
popping, or scrolling. Use the Search Tool window to search for instances, nets, and ports. 

To search for an instance, net, or port: 

1. From the View menu, choose Search Tool. The Search Tool window opens to the right of the Schematic window. This window 
is sizable and dockable. 

2. Select Instance, Net, or Port in the Search For area. 
Type the text you are looking for in the Name area. You can refine your search by specifying a Cell Type (on the Instance tab). 

 

Search Tool Window 

The Name and Cell Type fields accept regular expressions. Wildcard characters in regular expressions include:  

Wildcard What It Does 
? Matches any single character 
* Matches any string 
[] Matches any single character among those listed between brackets (that is, [A-Z] matches any single character in the A-to-Z 

range) 
/ This is the level-bordering symbol. “A/B” designates “object B, which is part of instance A.”   

3. Select from among the following search options:  

4. Case Sensitive - Select this check box if you want the search to return only items that match the case of the items you entered.  

5. Use Wildcards - Select this check box if you used wildcards in the Name or Cell Type fields. 

6. Search Range - Select a search range to limit your search to a hierarchical level. 
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 Using NetlistViewer with ChipEditor 

7. Click Start Search. The located objects, if any, appear in the Result list box. 

8. Select one or several objects in the Result list box, and then click either Select in Viewer or Select All in Viewer to locate your 
object(s) in the Schematic window. 

Using NetlistViewer with ChipEditor 
If both NetlistViewer and ChipEditor are open, items selected in either tool are automatically selected in the other.  

To use NetlistViewer with ChipEditor: 

1. Click NetlistViewer in Designer’s Design Flow window. NetlistViewer starts, displaying your netlist. 

2. Start ChipEditor. ChipEditor opens in a separate window and displays the logic and I/O modules on the device.  

 

ChipEditor Window 

3. Selecting a macro or instance in ChipEditor automatically selects it in NetlistViewer too. Likewise, selecting a macro or instance 
in NetlistViewer also selects it in ChipEditor. 

 
Item Selected in NetlistViewer 
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Using NetlistViewer with ChipEditor  

 
NetlistViewer Selected Item in ChipEditor 

 

For more information about ChipEditor, see the ChipEditor User's Guide.   
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 Using NetlistViewer Standalone with Timer 

Using NetlistViewer Standalone with Timer 
Use NetlistViewer with Timer to view and trace Timing paths. 

To trace paths using NetlistViewer and Timer: 

1. Choose NetlistViewer in Designer’s Design Flow window. Note: Your design must be compiled in order to start NetlistViewer. 
If it is not compiled, Designer prompts you to do so. NetlistViewer starts and displays your netlist. 

2. Click Timer in Designer Design Flow window. The Timer window opens.  

 

Timer 
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Using NetlistViewer Standalone with Timer  

3. Click the Timer Paths tab.   

 
Paths Tab  

4. Select a path set in the Path Set table. Paths within that set are displayed below in the Path Set window. 

5. Select the path you wish to expand. 

6. Double-click the path to expand it, or from the Edit menu, choose Expand Paths. The Expanded Paths window opens, as shown 
below. The Expanded Paths window displays the path in the Expanded Paths grid and a graphical representation of the path in 
the Graph window. 
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 Using NetlistViewer Standalone with Timer 

 
Timer Expanded Paths Window 

7. Select an instance in Timer's Expanded Paths grid or in the Graph window. The instance is highlighted in the NetlistViewer. 

 
Instance Selected in Timer 

8. Select the first register in the Timer path and locate it in the NetlistViewer. Follow the entire path in NetlistViewer.  
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Debugging Simulation Results  

 
Instance Selected in Timer Highlighted in NetlistViewer 

For more information about Timer, see the Timer User's Guide.  

Debugging Simulation Results 
The NetlistViewer tool is useful for debugging your netlist when simulation results are complex or conflicting with design constraints. 

In most cases, this occurs when the output of a flip-flop is being fed back into the input without a reset, preset, or clear input. 
NetlistViewer can help you verify that such a flip-flop configuration exists in the design. 

To locate and view the flip-flops: 

1. Click NetlistViewer in the Design Flow window. 

2. Zoom to locate the flip-flops. 
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 Identifying Paths 

Identifying Paths 
In this example, the NetlistViewer is used with Timer to identify the inputs of combinational gates. For more detailed information 
about Timer, see the Timer User's Guide. 

To identify these paths: 

1. From Designer, start NetlistViewer by clicking NetlistViewer in the Design Flow window. The NetlistViewer starts and displays 
your netlist.  

 

Starting NetlistViewer 
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Identifying Paths  

2. From Designer, start Timer by clicking Timer in the Designer Flow Window. Timer starts. 

 

Starting Timer 

3. In Timer, click the Paths tab. The Paths tab displays timing analysis information for several categories of paths (by default), 
known as “sets,” in the Path Set window. When you select a set in the Path Set window, the paths within that set are displayed in 
the lower table.  
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 Identifying Paths 

 

Timer’s Paths Tab 

4. Select a path. Timer displays the paths within that set in the lower table. 

5. Double-click a path (in the lower paths table) to see a graphical representation of the path. The Expanded Paths window opens. 

 

Expanding the Path 
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Identifying Paths  

The Expanded Paths window displays the path in the Expanded Paths table and a graphical representation of that path in the Graph window. 
Notice that the inputs of combinational gates are not displayed in the Graph window.  It is useful to know where these paths come from 
because they might indicate a false path that is never encountered and can affect the timing report. It is also important to know how other 
inputs to these macros interact with the indicated path, because this helps you define appropriate paths, which are essential for obtaining 
accurate timing reports. 

  

Combinational Gates in Timer’s Expanded Paths Window 
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 Identifying Paths 

6. Select the macro in the Graph window. The macro is located and selected in the NetlistViewer.   

  

Selected Macro is Located and Selected in the NetlistViewer 
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Viewing Buffers  

Viewing Buffers  
You can use NetlistViewer to see buffers inserted by your synthesis tool due to the high-fanout number of some signals. 

To view inserted buffers, click NetlistViewer in the Design Flow window. NetlistViewer starts and displays your netlist.   

In the following example, the fanout of DATAIN and RESET inputs of the design exceeds the specified value in the Synplicity 
synthesis tool. To reduce the number of fanout for these signals, Synplicity inserts two buffers in their path. You can use 
NetlistViewer to see these inserted buffers. 

 

Inserted Buffers  
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 Menus, Toolbar Buttons, and Shortcut Keys 

Menus, Toolbar Buttons, and Shortcut Keys 
The PC and workstation (UNIX) versions of NetlistViewer Standalone have the same menus. However, some dialog boxes may look 
slightly different due to the different windowing environments. The functionality is the same, though the locations of the fields and 
buttons on the dialog boxes may vary. Field names may also vary between platforms. 

• File menu 

• Edit menu 

• View menu 

• Help menu 

File menu 

Command Icon Shortcut Function 
Print 

 
CTRL + P Prints the display 

Print Preview   Previews the display 
Print Setup   Sets your printing options 
Close  CTRL + S Closes NetlistViewer 

Edit menu 

Commands Icon Shortcut Function 
Push 

 
CTRL + P Displays the next lower level in the design hierarchy 

Pop 
  

CTRL + O Displays the next higher level in the design hierarchy 

Top 
 

CTRL + T Displays the top level of the design hierarchy 

Highlight 
 

 Marks the currently selected object by turning it red 

Highlight 
Append  

 Highlights the currently selected object in red and adds it to a group, which includes that last 
highlighted object 

Un-Highlight 
 

 Unmarks the selected object only, returning it to yellow or blue 

Clear Highlight 
 

 Clears all marked objects, returning them to yellow or blue 
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Menus, Toolbar Buttons, and Shortcut Keys  

View menu 

Command Icon Shortcut Function 

Zoom Window 
 

 Drag out an area to enlarge 

Zoom Fit 
 

 Fits the entire design in the Schematic view 

Zoom In 
 

 Magnifies the view by a factor of 2 (scale = 2x) 

Zoom Out 
 

 Reduces the view by a factor of 2 (scale = .5x) 

Redraw   Redraws the screen 

Go to First Page 
 

 Displays the first page of the current level of the design 

Go to Previous Page 
 

 Displays the previous page of the current level of the design 

Go to Next Page 
 

 Displays the next page of the current level of the design 

Go to Last Page 
 

 Displays the last page of the current level of the design 

Toolbar   Hides or displays groups of toolbar buttons 

Search Tool 
 

 Hides or displays the Search window 

Hierarchy    Hides or displays the Hierarchy window 

Help menu  

Command Shortcut Function 
Help Topics  Displays the first Help topic for NetlistViewer, which provides you with 

an overview of the tool 
Reference Manual  Opens the NetlistViewer User's Guide (.pdf file) in Adobe Acrobat 
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 Contacting Actel 

Contacting Actel 
Actel Headquarters 

Actel Corporation is a supplier of innovative programmable logic solutions, including field-programmable gate arrays (FPGAs) based 
on Antifuse and Flash technologies, high-performance intellectual property (IP) cores, software development tools, and design 
services targeted for the high-speed communications, application-specific integrated circuit (ASIC) replacement, and radiation-tolerant 
markets.  

Address: Actel Corporation 
2061 Stierlin Court 
Mountain View 
CA 94043-4655 
USA 

Phone: 650.318.4200 
650.318.4600 

Technical Support 
Highly skilled engineers staff the Technical Support Center from 7:00 A.M. to 6:00 P.M. Pacific Time, Monday through Friday.  

Visit Tech Support Online 
For 24-hour support resources, visit Actel Technical Support at http://www.actel.com/custsup/search.html.   

Contacting Technical Support 
Contact us with your technical questions via e-mail or by phone. When sending your request to us, please be sure to include your full 
name, company name, email address and telephone number.   

E-mail (Worldwide): tech@actel.com 
Telephone (In U.S.): (650) 318-4460  

(800) 262-1060 
Telephone (Outside the US): Contact a local sales office 

 

Customer Service 
Contact Customer Service for order status, order expedites, return material authorizations (RMA), and first article processing. For 
technical issues, contact Technical Support. 

From Call 
Northeast and North Central U.S.A. (650) 318-4480 
Southeast and Southwest U.S.A. (650) 318-4480 
South Central U.S.A. (650) 318-4434 
Northwest U.S.A. (650) 318-4434 
Canada (650) 318-4480 
Europe (650) 318-4252 or +44 (0) 1276 401500 
Japan (650) 318-4743 
From the rest of the world (650) 318-4743 
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For more information about Actel’s products, call 888-99-ACTEL or visit our Web site at http://www.actel.com 

Actel Corporation • 2061 Stierlin Court • Mountain View, CA USA 94043 
U.S. Toll Free Line: 888-99-ACTEL • Customer Service: 650-318-4200 • Customer Service FAX: 650-318-2440 
Customer Applications Center: 800-262-1060 • Customer Applications FAX: 650-318-4600 

Actel Europe Ltd. • Dunlop House, Riverside Way • Camberley, Surrey GU15 3YL • United Kingdom Tel: +44 (0)1276 401 463• 
Fax: +44 (0)1276 401 490 

Actel Japan • EXOS Ebisu Bldg. 4F • 1-24-14 Ebisu Shibuya-ku • Tokyo 150 • Japan 
Tel: +81 (0)334-457-671 Fax: +81 (0)334-457-668 

Actel Hong Kong International • 39th Floor • One Pacific Place • 88 Queensway, Admiralty • Hong Kong 
Tel: +852.227.35712 Fax: +852.227.35999 
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