
ELEC516 Digital VLSI System Design and Design Automation
 (Spring, 2010)
Assignment 2

Due Date: 15/03/2010
Assignment 2(A): High Level Simulation and Synthesis

Objective
This assignment will guide you to be familiar with Design Analyzer for analyzing source files and VHDL simulator for high level functional simulation, carrying out synthesis from VHDL source code and verifying the design through gate level simulation.
Hand In
There are 7 questions in part(A), and only one question in part(B), please hand in a report answering the questions and some copies of your waveforms. schematic and layout.
Introduction
In this assignment, you are provided with the following,

· VHDL source code for a 4-bit array multiplier (array_mult.vhd)

· VHDL source code for a halfadder(halfadder.vhd)

· VHDL source code for a fulladder(fulladder.vhd)

· VHDL testbench file (array_mult.vhd)

· VHDL configuration file (cfg_array_mult.vhd)

· Test vector file for the adder (expect_vector)

You will be shown how to analyze and elaborate the adder source code in the Design Analyzer and how to analyze the testbench file, configuration file using VHDL Analyzer. By using the testbench file, configuration file and test vector for the adder, you can do a high level functional simulation for the array multiplier in VHDL simulator, VirSim. Then you have to use the analyzed result for high level functional simulation and synthesis. Since this is your first assignment, this document will guide you through how to use the tools to achieve your goal.

Background for Design Analyzer

Different Views of Design under Design Analyzer
Design Analyzer uses four different views of design, Design View, Hierarchy View, Symbol View and Schematic View. The four views let designer to check their design from different point of view as shown in the following.

· Design View

Shows all designs and sub-designs in memory. It is the initial view of the Design Analyzer. The designs are shown in icon. From the design view, the user can select a design for exploration or for setting design attributes and constraints.
· Symbol View

Shows a design as a black box with input and output ports. From this view, the user can set attributes and constraints for a design and its ports. Attributes specify design-specific information such as the arrival times and strengths of input signals. 

· Hierarchy View

Shows a design as a set of one or more named sub-designs. The view displays all the sub-designs in one level of a design hierarchy. The user can move up and down the levels of hierarchy. From the view, the user can see the relationship between levels of a design and work with the individual sub-designs.
· Schematic View

Shows a design as a schematic composed of instances, nets, and ports. An instance in a schematic can be  sub-designs.
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Note that on the left region of each view’s window, there are six buttons. Theses six buttons are used to transverse between different views. The figure below summarizes how to transverse between different views, after select the sub-design you want.
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Background for Testbench
Testbench is a model that is used to exercise and verify the correctness of a hardware model. A testbench has three main purposes,

· To generate stimulus for simulation. The stimulus is usually read from a text file.

· To apply this stimulus to the entity under test and collect the output responses.

· To compare output responses with expected values.

A testbench usually contains four files,

· Test vector file which contains input stimulus, one line for each simulation cycle.

· Testbench VHDL file to read input stimulus and apply this stimulus to entity component under test, compare simulated output with expected output and summarize all output conflict to another text file.

· VHDL source file for the entity component under test.

· VHDL configuration file for binding.

The following shows the relationship between each file,
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Background on VHDL Analyzer
VHDL Analyzer compiles VHDL source file and places intermediate files for each design unit in the design library mapped to the logical library name WORK. The analyzer can also generate a listing file that merges the source text with any error messages it produces. By default, it generates compiled event code for fast event simulation. Debuggable event code is always generated.

Background on Scirocco and Virsim
VirSim is a modular debug system. VirSim can simultaneously post process multiple data files or run an interactive session using a supported simulator. User can view the results of simulation and the source files used to generate the simulations in VirSim windows. Debug sessions can be saved in a configuration file, allowing the session to be resumed.

· Project Window

The Project Window is used to analyze, elaborate, and simulate VHDL or mixed VHDL and Verilog projects
· Interactive Window

This window is used to interactively control the simulator, send commands to it, and view the output of the simulator and its current state. Besides, it provides menu and tool bar controls, simulation history information, simulator control, and a pane containing pre-defined and user-defined buttons.

· Hierarchy Browser

It is used to locate and select scopes, signals, and ports for use in other windows, such as Waveform window. It works on any one of a number of simultaneously open design hierarchies. By navigating up and down the hierarchy, the user can locate the scopes and signals he want, and then drag them to other panes or windows for viewing or signal selection. Filters allow the user to selectively locate items for display.
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· Waveform Window

The window graphically displays signal waveforms over and within simulation time. The features let the user view and manipulate waveform data. For example, cursors and markers are used to find waveform edges and mark events so that the user can return to them later in the debug session. Specific events may be located by constructing expressions for use as breakpoints. Vectors can be expanded to show individual components.

· Source Window

The window displays the source code for the complete design and traces the behavior of statement execution. The HDL are concurrent modeling language. Therefore, the window is designed to display concurrent statement execution.

Assignment flow
1. High Level Simulation, also call pre simulation (vhdlan, scs)

2. Debug the pre simulation result (scirocco)

3. Synthesize (design_analyzer)

4. Post Simulation (vhdlan, scs)

5. Debug the post simulation result (scirocco)

Software and hardware requirement (read Appendix A for detail):

If you do the lab with PC, you need to install software Xwin and SSH or X-Manager.  Xwin and SSH are pre-installed in all the PCs in Rm.3119.

No specific requirement if you do the lab in Rm.3114(A) with workstation.

High Level Simulation
Setting up the environment for the Synopsys tools

1. Source the Synopsys Enviroment cshrc file as the following if you did not include it in the .cshrc_user file.
>source  /usr/eelocal/synopsys/courses/.cshrc
You can use following commands to check the version of Synopsys tools

>which vhdlan, >which scirocco, >which design_analyzer, etc
The message outputs  should be as follows
/usr/eelocal/synopsys/vcs_mx7.2/bin/scirocco

/usr/eelocal/synopsys/vcs_mx7.2/bin/vhdlan

/usr/eelocal/synopsys/syn-w2004.12-sp2/sparcOS5/syn/bin/design_analyzer

Notes: You may want to put the above command into your own .user_cshrc so that you do not need to type the above command every time you login to a new machine or invoking other terminalsIf you use PC to do the assignment, make sure you have open X-Win and write down the following command, so that the active window could be displayed on your PC.


>setenv DISPLAY your_ip_address:0.0
2. Copy the template directory to your home directory

>cp  -r /staff/ee/dept/public/elec516/template_vtvt  ~/elec516
There are totally three sub-directories in the template directory, “cadence”, “encounter” and “synopsys”.

High Level Simulation example (4-bit Array multiplier)

3. Analyze the design 

3.1. Under your directory, copy files needed for this simulation example

>cp –r /staff/ee/qianzl/public/vhdl   ~/elec516/synopsys/
3.2. Design Hierarchy

Several files are copied to the folder “/vhdl/”,we are going to simulate an 4-bit array multiplier and synthesize this design. The top design is array_mult.vhd, where we use bottom design halfadder and fulladder, therefore during analyzer we should analyze these two bottom designs first. 
The file cfg_array_mult is the configuration file of the design, which is used to define which architecture of tb_array_mult and array_mult to be used for the design. Later we will see that after synthesis, there will be another architecture named syn_arc of array_mult which is generated from the schematic, then the use of configuration file will be obvious.  But notice that we do not have a configuration here for the bottom design halfadder and fulladder, as  we will analyze these two entities first, the upper design will use the newest compiled architecture of them. 

                configuration cfg_array_mult of tb_array_mult is

   for TESTBENCH

       for UUT:  array_mult

           use entity WORK.array_mult(arc);

       end for;

   end for;

end cfg_array_mult;

tb_array_mult(TESTBENCH) is used to describe how to feed the test vector into your design array_mult for simulation and also check the results with the expected results, you can see the file named “error_vector” after simulation if there is any error. 

ADDER_4 is the design we try to write in VHDL and to be tested.

3.3. Go to “~/elec516 /synopsys/sim” directory and execute following unix commands to analyze VHDL source code.  The order of the files to be analyzed should be as following from the bottom of the hierarchy of the design.

>cd ~/elec516_lab1/synopsys/sim

>vhdlan  -nc  ../vhdl/halfadder.vhd
>vhdlan  -nc ../vhdl/fulladder.vhd

>vhdlan  -nc ../vhdl/array_mult.vhd
>vhdlan  -nc  ../vhdl/tb_array_mult.vhd

>vhdlan  -nc  ../vhdl/cfg_array_mult.vhd
Please check if there is any error or warning after you execute each unix command.

Note: The command ‘vhdlan’ will check syntax error of VHDL source codes and translate them into the intermediate files to be readable for the Synopsys tools.  You can find files *.mra, *.sim files created after analyzing the VHDL source code.  *.mra kept the record for most recently analysis.  *.sim files are necessary for simulation purpose.

4. Compile and Elaborate the Design

4.1. Execute unix command to compile and elaborate the design

>scs  -nc  cfg_array_mult
Note: This command will take a little bit longer to complete.  Please check if there is any error or warning after executing the command.

5. Simulate the design

5.1. edit a file named run.sim and type in the following content

run

quit

5.2. execute following command to simulate the design

>scsim  -nc  -include run.sim
6. Debug your design in GUI

In this session, you are going to check the waveform and debug your design in graphic mode.

6.1. Execute command ‘scirocco’ to open VHDL Simulator

>scirocco &
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Type in ‘scsim  -debug_all’ to open the simulator in debug mode (in debug mode you can use ‘step’ or ‘next’ to simulate your design line by line) and then click ok.  
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6.2. In the VirSim-Interactive window, click Window -> Hierarchy 

                   [image: image4.png]iy
e
Siminan
Bam o e

s o e
Srece
Sieoweoncs

i s

B e
Sats





The Hierarchy window shows you the module instance identifiers in the design hierarchy and the nets and registers in these instances.  The window has three panes:

· The Hierarchy pane in which you can reveal the module instances that are below the instances already displayed in this pane and then close the display of these revealed instances.

· The Search pane that allows you to search for signals and scopes in your design and displays these search results in this pane so that you can drag and drop (use middle mouse button or both mouse button) them into other windows.

· The Signal Select pane that shows you the nets and registers in an instance so that you can perform simulation operations on them in other windows.  These operations would be things like setting a breakpoint so that the simulator halts when a net or register changes value.

6.3. In the VirSim-Interactive window, click Window -> Waveform 
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In order to add signals into the Waveform window, you need to select these signals in the Hierarchy window.

In the Hierarchy window, click TB_ARRAY_MULT and then select signals XT

Click Add at the right bottom corner the Hierarchy window.

Use the same way to add other signals YT,PT into the Waveform window.

In VirSim-Interactive window, simulator control area, type in step time 3073000. (The unit for time is ps and it is defined in simulation library, or you can redefine it when you start the VirSim). then click OK. Now, you can check the simulation result in the Waveform window.
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If necessary, you can open more than one waveform window to monitor different set of signals.

To open the Source window you can click Windows -> Source in the Hierarchy window.
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There are more than one way to add the source code into the Source window.

1. The most simplest way is in the Hierarchy window, use middle button of mouse (in case your mouse does not have middle button, you should set the xwin to simulate the middle button by press two mouse buttons at the same time) drag and drop the TB_ARRAY_MULT into the Source window.

2. Or you can press the first icon in the mane bar to open the source code.
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Restart simulation:

In VirSim-Interactive window, click Sim -> Re-exec or Sim -> Invoke Sim.

You can try to simulate up to 30730 ps first, and then use Step or Next in User defined Button area to run the simulation step by step.  You can find the arrow in VirSim-Source window move one step when you click Step button once, and you can also find the waveform move one unit time step when you keep clicking Step button or Next button.
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Type ‘scsim  -debug_all’ in the window above.

Click OK.

Question 1: What files are created after you run scs to compile the CFG file? 

Question 2: Notice that in the source window, there are some lines with the green spot and some without. Why? Will the arrow (current line) point to those without green spot when you step the simulation in the interactive window?

Question 3: Explore the ways to use break point in source window. Also explore the way to use cursors to perform measurement.

Synthesis of a 4-bit Array Multiplier

In this part, you have to analyze, elaborate and synthesize the 4-bit array multiplier which you have behaviorally simulated before using design analyzer. In the synthesis process, you have to set the operating environment for your design. In order to match different design goals (power, area, timing), you can set different constrains before synthesis to optimize your design goal. The synthesis process is associated to a cell library. After synthesis, you will generate schematics and symbols for your design. Then, you need to simulate your synthesized design in gate level. 


(refer to Appendix B for background of synthesis)

7. Invoke Design Analyzer under directory ~/elec516_lab1/sysnopsys/syn

7.1. Type “ >design_analyzer & ”
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8. Check if you open the design_analyzer in the right directory.

In Design Analyzer window, click Setup -> Defaults
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Normally, can see a setting similar to box above, in case you see something like your_library.* in the box, that means you open the ‘design_analyzer’ in a wrong directory.

9. Start command window

9.1. Click Setup -> Command Window

The command window shows all the commands executed in the design analyzer and their results.  You should have a look on command window for every operation you have done in the design analyzer. 
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10. Analyze 4-bit Ripple Carry Adder (RCA) VHDL source file

10.1. Click File -> Analyze…

[image: image13.png]Analyze File

File Nane(s): | halfadder vhd,

Direstory: /staff/ee/zedsisy/elecs18/synopsys/vhdl

+./ (Move up one directory)
array_mult,vhd

cfg_array_mult.,vhd

Fulladdervhd

th_array_nult vhd

|

File Fornat: WL
Library: | WORK

DEFALT

=

=)

™ Create New Library if it Tossn’t Exist





10.2. Open “VHDL” directory in the upper folder

10.3. Select “halfadder.vhd”

10.4. Check “Create New Library if it Doesn’t Exist”

10.5. Click “OK”

10.6. Check in the command window or the Analyze pop-up window if there’s any error or  warning. Return code 1 is expected. 

Use the same steps to analyze fulladder and array_mult
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10.7. Resolve those errors and warnings if there’s any before proceeding

11. Elaborate design

11.1. Click File -> Elaborate…
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11.2. Select “WORK” or “DEFAULT” in the Library
11.3. Select “array_mult(arc)”in  the Design

11.4. Check “Re-Analyze Out-of-Date Libraries”

11.5. Notice that if the design require generic mapping, the parameters are inputted at the “Parameters” text box

11.6. Click “OK”

11.7. Check in the command window or the Elaborate pop-up window if there’s any warnings or errors. Return code 1 should appear

11.8. After elaboration, three design icons array_mult,fulladder and halfadder will appear in the design view window
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Analyze and Elaborate are always used together to read in VHDL design files. The Analyze command reads a VHDL file, checks for proper syntax and synthesizable logic, and stores the design in intermediate format. Use Analyze to read in each sub-design as well as the top level of the design hierarchy. The Elaborate command creates a design from the intermediate format produced by Analyze. The elaborate command replaces the HDL operators in the design with synthetic operators and determines the correct bus sizes. Use Elaborate on the top level and on sub-designs to which need passing parameters

12. Link design

Link design is to check if all the data for design exist or is reachable, if it returns some instance which is unsolved, it means the instance is missed.  This operation will first try to find the design in the memory (actually, all the data stored in the memory is shown in the Design Analyzer window), then find the working directory and finally find the libraries path setting in the setup file.

12.1. Click and select array_mult icon

12.2. Click Analysis -> Link Design…

12.3. Leave everything as default

12.4. Click “OK”

Return code 1 is expected.

13. Check Design

13.1. Click Analysis -> Check Design…

13.2. Leave everything as default

13.3. Click “OK”

13.4. Check if there are any warnings and errors. A return code 1 is expected.

14. Save design before synthesis

14.1. Click File -> Save as…

14.2. Open “db” directory

14.3. Type “array_mult_before_compile.db” in the File Name

14.4. Check “Save All Designs in Hierarchy”

14.5. Click “OK”

Setting Operating Environment
15. Set Input Driving Strength

15.1. In symbol view of array_mult, select one of the inputs

15.2. Click Attributes -> Operating Environment -> Drive Strength…

15.3. Type “50” for both Rise Strength and Fall Strength.

The time unit for rising and falling transition delay is ‘ps’.

15.4. Click “Apply”

15.5. Repeat for other inputs

16. Set Output Capacitance Load and Fanout Load

16.1. In symbol view of array_mults, select one of the outputs

16.2. Click Attributes -> Operating Environment -> Load…

16.3. Type “100” in Capacitive Load.  The unit for cap load is ‘ff’.

16.4. Click “Apply”

16.5. Repeat for other inputs

Setting Design Constraints (Timing)

17. Define Virtual Clock

17.1. De-select any input/output port

17.2. Click Attribute -> Clocks -> Specify…

17.3. Clock name: “vclk”

17.4. Period: “10000” (10ns)

17.5. Uncheck “Fix Hold” and “Don’t Touch Network”

17.6. Click “Apply”

Notes: Virtual clock is not a real input for the design.  It is for synthesizing purpose; it is reference timing information for you to set input delay, output delay and delay for your design.

18. Define Input Arrival Time (Relative to vclk)

18.1. Select one of the inputs

18.2. Click Attribute -> Operating Environment -> Input Delay…

18.3. Relative to Clock: “vclk”

18.4. Max Rise, Max Fall, Min Rise, Min Fall: 0 (0ns)

18.5. Click “Apply”

18.6. Repeat for other inputs

19. Define Output Ready Time (Relative to vclk + T)

19.1. Select one of the outputs

19.2. Click Attribute -> Operating Environment -> Output Delay…

19.3. Relative to Clock: “vclk”

19.4. Max Rise, Max Fall, Min Rise, Min Fall: 1000.

The time unit is ‘ps’.

19.5. Click “Apply”

19.6. Repeat for other outputs

20. Setting Optimization Directives

20.1. Select array_mult icon

20.2. Click Attributes -> Optimization Directives -> Design…

20.3. Check “Structure Logic”

20.4. Check also “Apply timing Driving Structuring”

20.5. Leave other as default

20.6. Click “Apply”

21. Setting Constraints for timing-critical design

21.1. Select array_mult icon

21.2. In command window, type ‘set_max_delay 0 –from all_inputs()’ and then press enter

Note: in case you want minimum area for design, you can execute following command in command window, ‘set_max_area 0’.  Every time when you change from timing critical to area critical, you need to remove the constraints and re-do from the step 15.

22. Save Design before Compilation

22.1. Select array_mult icon

22.2. Click File -> Save as…

22.3. Open “db” directory

22.4. Save as “array_mult_min_time_before_compile”

22.5. Check “Save All Designs in Hierarchy”

22.6. Click “OK”

The relationship between the input delay , output delay and target circuit delay can be expressed in the following figure.
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23. Perform Synthesis

23.1. Select array_mult icon

23.2. Click Tools -> Design Optimization…

23.3. Check “Map Design” also “High” Map Effort

23.4. Check “Verify Design” also “High” Verify Effort

23.5. Check “Allow Boundary Optimization”

23.6. Click “OK”

24. Save Synthesized Design

24.1. Select array_mult icon

24.2. Click File -> Save as…

24.3. Open “db” directory

24.4. Save as “array_mult_min_time_after_compile.db”

Question 4: Compare the schematic view before and after compilation. Is there any difference? Are the gates numbers the same? How about the name of the gates?

Analysis of Synthesized Result
25. Critical Path Timing(max)

25.1. In the schematic view, click Analysis -> Highlight -> Critical path, the critical path is highlighted

25.2. In the command window, type “ report_timing –delay max –max_paths 10” to observe the 10 maximum delay paths in our design  in the command window.

26. Reporting

26.1. Click Analysis -> Report…

26.2. Check “Area” and “Timing”

26.3. Click “Apply”

Question 5: Capture the schematic for both design constraints (timing critical and area critical).  Report the critical path delay and area for both design constraints.
Gate Level Back Annotation

27. Export the Design in VHDL

27.1. Select array_mult icon

27.2. In the command window, execute the following commands

change_names –rule vhdl -hierarchy

write –format vhdl –hierarchy –output ../vhdl/array_mult_compiled.vhd

27.3. Go to the directory “vhdl/”, check the file “array_mult_compiled.vhd”. Is there any difference from the original source file?
In these steps, we export the synthesized design in VHDL format which is in gate level. Then we repeat the past steps to run gate level simulation as follows. 
28. Create the Configuration File

28.1. Copy the old configuration file to “cfg_array_mult_compiled.vhd”

28.2. replace the array_mult(arc) by array_mult(SYN_arc)

28.3. Save the new configuration file

29. Now you need to repeat the step 3 to step 6 with new VHDL files.But you don’t have to analyze the halfadder and fulladder this time
29.1. enter “sim” directory

29.2. array_mult_compiled.vhd, tb_array_mult.vhd, cfg_array_mult_compiled.vhd

29.3. Compile the CFG file 

30. Repeat step 6 to view the waveform for post simulation.

The SYN_arc architecture in file array_mult_compiled.vhd is automatically generated in Design Analyzer. The Design Analyzer will read in the design with the architecture name (arc). After synthesis, the Design Analyzer will add the SYN_ in front of the original architecture name.

Question 6: For timing critical synthesis, capture the waveform for both pre-simulation and post-simulation then describe the difference between two results and explain what makes the difference?
Question 7: Explore the Design Space by Using Design Analyzer: Re-synthesis the design from “array_mult_before_compile.db” with other constraints other than timing critical and area critical. E.g. change the period of virtual clock, input delay, output delay, maximum area or maximum delay, etc.  You should have at least three synthesized designs finally. Plot the area vs. delay curve to see the tradeoff between the parameters. You are allowed to use any options in the design analyzer. 

ELEC516 Digital VLSI System Design and Design Automation (Spring, 2010)

Assignment 2(B): Auto Place and Route in Encounter

31. Go to directory “syn” and open design analyzer

31.1. Open the saved design adder_4_min_time_after_compile.db from “File( Read”.

31.2. In the command window, execute the following commands

change_names –rule verilog -hierarchy

write –format verilog –hierarchy –output ../vhdl/array_mult_compiled.v

In this step, you export the design in verilog format. The verilog file is used to place and route the design because the tool encounter only accepts verilog netlist. 
Go to directory “encounter”

32. Source the Encounter tools as following if you did not include it in the .cshrc_user file.
32.1. >source /usr/eelocal/cadence/ic5141a/.cshrc
32.2. >source /usr/eelocal/cadence/soc52/.cshrc

32.3. open the Encounter 

>encounter

Note: Don’t add mark ‘&’ after encounter, so that the UNIX shell will be Encounter console.

33. Click Design ( Design Import

34. Following the following step add the array_mult_compiled.v into the list of Verilog 
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After successfully import the design into Encounter, the green box will appear. 
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35. Click Floorplan – specify floorplan [image: image27.jpg]Specify Floorplan
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36. Global Connection

36.1. Click Floorplan( Connect Net Connections..

36.2. Following the setting listed in the table below and  add the connects to the list
36.3. Click Apply, and then Check. The Check command check for unconnected pins in your design. Verify and fix if any warnings or errors appear in the encounter console.

	Setting
	Setting1
	Setting2
	Setting 3
	Setting 4
	Setting 5

	Connect Region
	Pins: vdd
	Tie High
	Pins: gnd
	Tie Low
	Pins: vss

	Scope Region
	Apply All
	Apply All
	Apply All
	Apply All
	Apply All

	To Global Net
	vdd
	vdd
	gnd
	gnd
	gnd


[image: image29.png]Global Net Connections.

Power Ground Comection
Comect

A‘ B e —
i

= v Under Region: bc[00  I:[00  usc[o0 o0

> v

ToGoballietlgns

1 Overtteporcomecton
st vt ot |

vy o | et | e | o |





Click Power( Power Planning ( Add Rings
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Power ( Power Planning ( Add Stripes
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Click sroute(special route, leave everything default and click ok.
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Click Place ( Standard cells and blocks, check the options as the figure shows. Be sure not to include any optimization step when placing and routing.
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Click Place -> Filler -> Add Filler..
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Click Route ( WRoute, leave everything as default and click OK
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Well done!!

37. You have finished the auto place and route in Encounter.  Now you are going to verify any mistake in the layout.

37.1. Click Verify ( Verify Connectivity, leave everything as default and select OK.

37.2. Check the Encounter console if there any error or warning in connectivity.

Following is the sample console output for connectivity checking.


[image: image40]Click Verify ( Geometry, leave everything as default and select OK.  Following is the sample console output.
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Next step you are going to extract the routing timing information and back annotate into Design Analzer to find the critical path delay with routing information and back annotate into Scirrocco to perform the post layout simulation.

Routing Delay Information Extraction:
38. Click Timing ( Extract RC and the select OK
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Check the Encounter Console output

Click Timing ( Calculate Delay, then select OK
Click Timing->calculate delay, then click ok.

[image: image43]
All the jobs in the Encounter have been done.  The routing timing information has been 

saved as a file array_mult.sdf in Encounter working directory.   Now you are going to back annotate this file into Design Analyzer.

39. Click  Design ( Save Design, save the design as “array_mult.enc”

40. Open a new shell or close the Encounter, source the Synopsys .cshrc file.

41. Go to directory ‘synopsys/syn’ and open the Design Analyzer.

42. Open the saved design “array_mult_min_time_after_compile.db” by “File(Read..”.

Type the following command in the command window

change_names –rule verilog –hierarchy

43. If the design hierarchical has several designs, select the top design and click Analysis ( Link Design to check if all the sub-blocks and instances have been loaded into the Design Analyzer.  Return code ‘1’ is expected.  In case there is any message about the unsolved instanced, it means some instances were missed, you need to read these missed instances into Design Analyzer before you move to next step.

44. Select the array_mult, click Analysis ( Report, check Timing and then click Apply.  The report output shows the critical delay without routing information is 3027.47 ps.
45. Click Setup ( Command window, you need to execute following commands to read in the routing timing information from Encounter

 

read_sdf ../../encounter/arry_mult.sdf

Return code ‘1’ is expected for reading in the SDF file.

46. Select the array_mult icon, Click Analysis ( Report to report timing again.
You will find the critical path delay is 3305.91ps now.  It is the post layout critical path delay.

Next step we are going to back annotate the SDF file into the Scirocco for the post layout simulation.  Because the SDF file from Encounter cannot directly input into Scirocco, you need to write the SDF again from the Design Analyzer.

47.  Select array_mult icon, and in the Design Analyzer command window execute following command.
change_names –rule vhdl –hierarchy

write_sdf array_mult.sdf
Return code ‘1’ is expected for successfully execute the command.  You can open the file array_mult.sdf in directory syn/ and compare the file array_mult.sdf in directory encounter/.  
Post Layout Simulation

48. Goto ‘synopsys/sim’ directory
49. Copy the .sdf file to the sim  directory

>cp ../syn/array_mult.sdf  ./

50. Open Scirocco by typing the following message in the simulator invocation dialog

scsim –debug_all –sdf /tb_array_mult/UUT/:array_mult.sdf
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Check the history window in the Scirocco to check if there any error when reading in the SDF file.  The figure above shows the example output in the history window

For some design post layout simulation, you may get the following error messages of negedge and posedge, you can just ignore them.
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Now in Interactive Window, Click Sim ( Invoke Sim, reopen the simulator without SDF file
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Question B1, copy a picture of your simulation result for post_schematic and post_layout respectively, and compare the waveform at a certain time , tell what’s the difference between them ?

ELEC516 Digital VLSI System Design and Design Automation
(Spring, 2010)
Appendix A: Unix Setup (Modified from ELEC301 Lab. Materials)
Login the EE workstation via PCs (in Rm3119)

Step 1.
The EE workstations are using Unix system.  You can remotely login the EE workstations.  Following the steps below to login the EE workstations via PCs  (labs in Rm3119).

1.1 In the PC, run the X-Win program first, Programs (X-Win32 5.x ( X-Win32, then on the screen displayed click on ‘Cancel’.
1.2 Then, run the SSH Secure Shell program;

Programs ( SSH Secure Shell ( Secure Shell Client

   
[image: image48.wmf] 

 

eesu9.ee.ust.hk

 

 

ee_abc

 

 


1.3 If you login successfully, you will have the display looked like this,

    
[image: image49.wmf] 

eesu9:ee_abc:1>setenv  DISPLAY  ??????:0.0

 


Basic UNIX Commands


Now you are using the EE workstation which is running under Unix system. The most common UNIX commands are listed below.  You should try them out and be familiar with them.  If you need help, the UNIXhelp for Users (http://www.ust.hk/itsc/unix/UNIXhelp1.3/Pages/) is useful to you.  Or you can use the ‘man’ command to look at the details of each command, e.g. in the command prompt, type in ‘man cp’ (command ‘cp’ is used for copying files), the manual of using ‘cp’ command will then be displayed.
	To ... 

	UNIX command

	display user’s account quota
	fs lq

	display the jobs running in the workstation
	top

	display a list of files
	ls

	display all files (including the hidden files)
	ls -al

	display the content of the file
	cat

	display files with pauses
	more

	copy files
	cp

	rename files
	mv

	delete files
	rm

	delete directories
	rmdir

	create directories
	mkdir

	change the working directory
	cd

	print a file
	lpr

	display the print queue
	lpq

	remove the print job
	lprm


Changing passwords

The passwords for new accounts/users (for EE network) are pre-assigned by the system. In order to minimize password intrusion, after logging in the system for the first time, you are advised to change this password yourself.

2.1 Activate the console window by clicking on this window using the mouse.

2.2
At the UNIX command prompt, type in "passwd" and press < Enter >.

2.3
Type in your pre-assigned password at the "Old password:" prompt and press < Enter>.

2.4
Type in your new password at the "New password:" prompt and press < Enter >. (your new password should contain 8-14 characters and the word must not be found in a dictionary.)

2.5
Retype your new password again at the "Retype new password:" prompt for verification and then press < Enter >.

2.6 Your new EE network password is now activated, logout the machine and login again with your new EE network password.  If you need assistance please ask TAs for help.

Special files in your EE account; the Auto-execute C-shell Scripts

To list out all files in your EE account, type in ‘ls –al’ at the UNIX command prompt.

The first file to note; File name: .cshrc

This file should NOT be modified.  The C-shell executes this file located in user’s home directory each time a new C-shell is invoked, including the login C-shell. 

The second file to note; File name: .cshrc_user

This file is executed after executing the .cshrc file.  The .cshrc_user file can be modified by the users if necessary.  For example, setting up C-shell history, path, prompt and aliases.

Setting up the environment for Running Synopsys Design Analyzer and Encounter

Step 3.
We are going to set the environment for running Synopsys Design Analyzer and Encounter. 

3.1
Add the following line in your .cshrc_user  file by using a text editor.


(e.g to use the Texteditor, type in ‘textedit &’ in the command prompt, or pico, vi, etc)

   
source /usr/eelocal/cadence/soc3.2/.cshrc

source /usr/eelocal/synopsys/courses/.cshrc

3.2
In order to use this new setup, type the following UNIX command at the UNIX prompt,

       

>source  ~/.cshrc


In the assignment, you are required to copy the elec516_lab1/ folder to your home directory. Actually the folder contains the necessary files for you synthesis, simulation place and routing. Check what file is inside the folder encounter/, synopsys/syn, synopsys/sim by command “ls –al”

More about the EE workstations 

The workstations of eesu1 to eesu10 are located in Rm3114A.  Instead of remotely connecting to workstations as you did in this lab, you can also directly login the EE workstations in Rm3114(A).  
ELEC516 Digital VLSI System Design and Design Automation 

(Spring, 2010)
Appendix B: Background of Synthesis

1. Optimization within Design Compiler (Design analyzer)

In VLSI design, usually 3 factors are to be optimized. These 3 factors are area, timing/ performance, power consumption. These 3 factors are in trade-off relationship (i.e. if one factor gets better, others may get worse). You can set design constraints before synthesis to favorite your design goal (any one of the 3 factors). Usually, we set different constraints on timing, optimize and select a better result in area which meets our design goals or vice versa.

1. Synthesis and optimization flow summary:

 In Design Analyzer, Synthesis and optimization flow includes following steps:

• Specify symbol, link and target library in file: .synopsys_dc.setup;

• Specify library mapping in file: .synopsys_vss.setup

• Analyze and elaborate design source files;

• Link design to resolve design and library component references for the design;

• Check design for obvious errors, such as unconnected ports, cells with no input or output pins, differing pin counts between a named component and its corresponding library component, multiple drivers for a port, or a recursively defined hierarchy.

• Save the design as version l;

• Select Technology model -- select operating condition and wire load model;

• Define operating environment -- input drive strength, output cap. load and fanout load;

• Set design constraints for your design goal -- define reference clock, input delay time, output delay time, point to point timing constraint, area or timing critical, min fault coverage, max area;

• Save the design with constraints as version 2 before optimization. The next time you read this version, the constraints are associated with the design;

• Compile (optimization) based on your design constraints;

• Analyze the timing and area of the synthesized result;

3. What is Operating condition and wire load model

Operating condition and wire load model are modeled inside the technology library. Operating condition includes variables like temperature, supply voltage and manufacturing process. It is usually predefined and group the variables into a set of best-case, worst-case and typical case models. They vary from one library to another.

In the absence of physical routing wire information, Design Compiler uses statistically generated wire load models to estimate wire lengths in a design. The wire load models provided in the technology library define a fanout to length relationship.

4. What is Operating environment

Operating environment includes specifying input drive strength (rise and fall) and output cap. load and fanout load.

Input drive strength and output cap. load unit are predefined in the technology library. It is equivalent to a standard load unit. A blank or zero input drive strength means infinitive drive strength.

Design Compiler adds fanout load value to all other cap. load on the output and tries to make resultant load less than the output’s maximum load capable to drive. Therefore, output fanout load is usually zero (or blank) to avoid overdrive. On the other hand, if you want add some design margin, you can use output fanout load.

5. Design constraints

Design constraints includes define reference clock, input delay time, output delay time, point to

point timing constraint, area or timing critical, min fault coverage, max area.

Design Compiler use defined clock as a reference to measure input delay and output delay time. In sequential circuit, you can define clock source as clock reference. In pure combinational circuits, you can define virtual clock as clock reference. Virtual clock is not associated to any input but you still have to define it (refer to lab procedure for how to do it). After defining clock reference, you can specify input arrival time and expected output delay time. The figure below shows you the relationship between reference clock and input and output delay.

For some sequential circuit, if you want to constrain the point to point delay for particular path of combinational part, you can use point to point constraint provided that it does not conflict with other design constraints. 

If you want to take timing as the highest precedence in design constraints, you can specify the reference clock, input delay, expected output delay, enable timing critical, disable area critical, blank

max area
[image: image50.emf]
6. How to set design constraints for min. area design goal

Enable area critical, assign a very small value to max area (e.g. 1) and leave all other constraints blank or disabled.

7. Remove all design constraints from a design with constraints setting

In the command window of Design Analyzer, type remove_constraint -all. This is very useful when you want to synthesize same design for different constraints.

8. Three terms to be discussed for synthesis

	Terms
	Definition
	Use
	Method

	Don’t touch
	When you want a subdesign block to remain unchanged during optimization, you can set it don’t touch
	For register bank subdesign, improvement in area and timing is little. Make it don’t touch can save synthesis and optimization time
	Click the subdesign icon of design/symbol view, then click on 

Attribute (Optimization directive (Design

Don’t touch: [enabled]

Click on Apply

	Ungroup
	When a subdesign is ungrouped, its level of hierarchy is removed and it is merged with the surrounding logic
	To combine combinational blocks to minimize redundant logic during optimization
	Click the subdesign icon of design/symbol view, then click on 

Attribute (Optimization directive (Design

Ungroup: [enabled]

Click on Apply

	Uniquify
	It creates one copy of the subdesign each time it is referenced in the design, then assigns a unique design name to the copy
	When a subdesign block is referenced more than once
	Click the top icon of design view, then click on 

Edit (Uniquify (Hierarchy

Command window will display which design is uniquified
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Check the History window if there any warning or error when you open the simulator.

















Use the same way to fill in the LEF Files, Max Timing Libraries fields and check 


Top Cell for Auto Assign.











Change to Advanced Tap, and fill in vdd for Power Nets and gnd for Ground Nets.


Then click OK.














******** Start: VERIFY CONNECTIVITY ********


Start Time: Sat Sep 15 23:45:37 2007





Design Name: array_mult


Database Units: 100


Design Boundary: (0.0000, 0.0000) (168.1400, 126.6400)


Error Limit = 1000; Warning Limit = 50


Check all nets





Begin Summary 


  Found no problems or warnings.


End Summary





End Time: Sat Sep 15 23:45:37 2007


******** End: VERIFY CONNECTIVITY ********


  Verification Complete : 0 Viols.  0 Wrngs.


  (CPU Time: 0:00:00.0  MEM: 0.000M)








    Verification Complete : 0 Viols.  0 Wrngs.





**********End: VERIFY GEOMETRY**********


 *** verify geometry (CPU: 0:00:00.2  MEM: 11.4M)








encounter 1> RC Extraction for instance array_mult


RCMode: Default


Capacitance Scaling Factor   : 1.00000


Coupling Cap. Scaling Factor : 1.00000


Resistance Scaling Factor    : 1.00000


Shrink Factor                : 1.00000


Default RC extraction is honoring NDR/Shielding/ExtraSpace for clock nets.


Using detail cap. scale factor for clock nets.


RC Extraction Completed (CPU Time= 0:00:00.0  MEM= 201.2M)





In the host name field, type in which EE workstation you are going to login.  e.g. eesu9.ee.ust.hk


You can login to 20 EE workstations, they are eesu1 to eesu10, eesu114 to eesu118 and eesu125 to eesu130.





Type in your EE account name. Your EE account name is the same as your ITSC account name.





Then click on ‘Connect’.  It will then ask you to key in the password.  If you are a new EE account user,  TA will provide you the password for the first time login. 





  Press Enter/Space to connect





Type in this command:


“setenv  DISPLAY  ??????:0.0”,  


change ‘??????’ to your PC’s name (or type in the IP address of the PC you’re using).  Then, what is running in eesu9 is able to be displayed on your PC.





Your EE account name





The EE workstation in use





In the Ring Configuration box, change the Width and Spacing to 1.2um and check Offset to Center in Channel.





Write “filler” in the Cell Name(s)  





encounter 1> RC Extraction for instance array_mult


RCMode: Default


Capacitance Scaling Factor   : 1.00000


Coupling Cap. Scaling Factor : 1.00000


Resistance Scaling Factor    : 1.00000


Shrink Factor                : 1.00000


Default RC extraction is honoring NDR/Shielding/ExtraSpace for clock nets.


Using detail cap. scale factor for clock nets.


RC Extraction Completed (CPU Time= 0:00:00.0  MEM= 201.2M)


encounter 1> delayCal Option :  -sdf array_mult.sdf -idealclock 


delayCal Mode   : setDelayCalMode  -default 


Topological Sorting (CPU = 0:00:00.0)


Number of Loop : 0


Start delay calculation (mem=201.219M)...


Handling High Fanin Net......


Handling 0 High Fanin Net (CPU = 0:00:00.0) 


**WARN: Unable to find and calculate resistance for via M2_M1, assign 4.0 ohms.


**WARN: Unable to find and calculate resistance for via M3_M2, assign 4.0 ohms.


**WARN: Unable to find and calculate resistance for via M4_M3, assign 4.0 ohms.


**WARN: Unable to find and calculate resistance for via M5_M4, assign 4.0 ohms.


.


Printing SDF File.....


Delay calculation completed.


(0:00:00.0 201.219M 0)








Delay Calculation Summary:


   Number of nets with pin count greater than 100  : 0


   Number of nets using excludenet file            : 0


   Number of nets using set_resistance             : 0


   Number of nets using default delay              : 0


   CPU Time (0:00:00.0)











ELEC516 (Spring, 2010)
             Dept. of ECE, HKUST              Assignment1--Page 35 of 36

_1137917140.vsd
Design View�

Schematic View�

Symbol View�

Hierarchical View�

Upward Button�

Symbol Button�

Schematic Button�

Upward Button�

Downward Button�

Hierarchical Button�

Hierarchical Button�

Schematic Button�

Upward Button�

Symbol Button�

Downward Button�


_1137940302.vsd
Test Vector File�

Testbench VHDL File�

Design VHDL Source File�

Configuration File�

Read Line�

Configuration�

Inputs�

Configuration�

Outputs�


_1117535909.doc
[image: image1.png]5H secure shell

[l e Eck o sodow beb
| ar |28 Baenlan % o
|| £ Quickconect (3 prfies ‘

598 Secure Shell 2.4.0 (Build 163] ‘
Copyright (] 2000 55K Commmicarions Security Corp - hrtp://ww.ssh.con/

This copy of S5H Secure Shell is licensed for educational, charity,
and personal recreational/hobby use.
by commercial use reguires a separate license.

This progran uses RSA BSAFER Crypto-C by RSA Security Inc.

ot connected - Pess Enter/Space to connect

=
e Ton e )

[Connect ta Remore Host S x|

Host Name: Corfiest
User Name: i
Port Number 2

Authertication Methad: [Fassword -











eesu9.ee.ust.hk







ee_abc
















_1117535439.doc
[image: image1.png]Err

@ ar(8s Bea nlan s o
|| &1 quk comect (1 profes -

Last login: Tue Jun 3 18:52:3L 2003 from uststf2.ust.hk






eesu9:ee_abc:1>setenv  DISPLAY  ??????:0.0












