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Objective

After this tutorial, you should gain essential understandings about ASIC design �ow. Two popular tools for
logic synthesis and auto placement/route would be introduced. A lab material is also supplied to help you
understand the �ow.

Background on ASIC design �ow

Front End and Back End design are the most popular division between ASIC �ows. Front end is more
concerned with design logic while Back end is more related to the physical aspect of the design. The whole
process is shown in Fig. 1.

Front End Design

Each design process begins with a speci�cation. The function of a system is speci�ed and partitioned into
submodels or systems to improve the e�ciency and robustness. After speci�cation. each module is designed
to meet its own function. In digital domain, this design is usually modeled in a hardware description language
(i.e., VHDL, verilog). Behavior simulation is devised to check the design function.

After the desired behavior is veri�ed, we move to a stage called logic synthesis. In a fully custom design,
this stage may be completed by human beings. Here, we only refer standard-cell based design (a semi-custom
design strategy) where this step is accomplished by computer tools. Several key transformations are made
here:

1. The design logic function is extracted from the HDL for each input and output. The result logic is then
presented in basic Boolean equation;

2. All the extracted logic function is simpli�ed to achieve better area/ power/ timing;

3. All the logic is then mapping into speci�c cells provided in the standard-cell library. This library is
usually provided by foundry;

4. The timing/area/power is estimated and optimized to meet certain design constraints;
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The output from logic synthesis is a netlist describing the interconnection of library gates. You will see it
soon. Then you can utilize this netlist and the library gate model to device a pre-layout simulation which
would include the cell delay into consideration and make the result more realistic. If this simulation passes,
we hand over the netlist to the back end guys.

Figure 1: ASIC Design Flow

Back End Design

The back end process focuses on turning the netlist into a physical layout. This involves cell placement and
interconnection routing (for signals). Good cell placement and interconnection routing tools would result in
a signi�cant better design in terms of area/power/timing. So several iterations of optimization would be
performed here to achieve this goal. Usually back end design requires an understanding of tools and real-life
experiences.

Note on Design Presentations

Probability a better way to see this process is to take a look at your design presentations:

1. You write a code in VHDL/Verilog;

2. Simulate your design in behavior simulation; We call it behavior simulation in a sense that at this
stage, we do not have any information about the physical implementation of your design. Only the logic
function is veri�ed. There's no timing information in it.
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3. Synthesis your design and get your design netlist; This stage your design has been mapped into structure
connections with standard-cells. Standard-cell library provides a forest of logic cells for you to implement
all possible logic functions (actually, a 2-input nand gate can implement all possible logic); This netlist
�le is usually in Verilog format;

4. With the netlist �le, you can do Pre-Layout simulation with a standard library verilog �le. The standard
library �le is only to describe cell functions and their delay information. This time, the simulation result
is more realistic in the sense that all the cell/gate delays in your design is included. However, since
we still haven't actually layout the cell, we do not know the wire delay (we do not know the distance
between to cells, so their connecting wire lengths);

5. Placement & Route your design. This time, you get a physical design. You can extract the wire delay
information and another netlist (since during this step, some logic might be revised for better timing);

6. With the wire delay information and the �nal netlist, you can redo your simulation (Post-Layout simu-
lation). If it passes, then congratulations! You probability have a functional design (But function is only
one concern, power/area are also important).

Tutorial Setup

In this tutorial, we would use a simple 16-bit multiplier design to demonstrate the ASIC �ow. A template
folder �elec516_lab� (or eesm518_lab) contains all the necessary �le and setup information for you to practice
and use for your project. (See �Before Getting Started� section to download this folder)

The sub-folder �encounter� is used when you to Back-End place and route. There are two �les in it.

• The �LEF� �le contains the placement information for each standard cell (i.e., size, dimensions, in-
put/output locations);

• The �lib� �le is the timing library containing the cell and wire delay information;

You are encouraged to open these two �les with a text editor to get a sense.

The �synopsys� folder contains synthesis and simulation setup.

• �db� folder is for you to store your synthesis results. it is short for your design library database;

• �libs� folder contains standard cell library (�db� �le) and symbol library (�sdb� �le) for synthesis use;

• �sim� folder is for your behavior simulation;

• �syn-sim� folder is for your gate-level (pre-layout/post-layout) simulation. There're verilog �les of the
standard cell library inside. Since after synthesis, your design is present in standard cells. So this verilog
�le contains the cell function and delays for you to simulate your design in a more practical situation;

• �syn� folder for you to synthesize your design. You must do it in this folder since it contains a setup �le
�.synopsys_dc_setup� (hidden, use ls -a to see it);

• �verilog� folder for you to put your source code;
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Before Getting Start

Download the tempelate folder :

>cp ~qianzl/public/elec516-lab . (copy the folder to your current working directory)

In order to set up the environment for the tools ( so that the system can recognize the licenses and versions
for sysnopsys and cadence tools) , in �elec516_lab� (or � eesm518_lab�) folder,we need to source �.cshrc_user�
�le �rst .

> source .cshrc_user

After this step , you can type commands like

> which design_vision

to check the current version of the tools which we'll use.

Note: in many cases , if the system tells you �command not found� , it's most likely you haven't �source
.cshrc_user� yet or the previous source action is no longer valid after reboot. You can source .cshrc_user �le
again to �x this problem.

Behavior Simulation ( For VHDL input )

1) Go to the �elec516_lab/synopsys/sim� folder .

2) In �elec516_lab/synopsys/sim� directory execute the following commands to analyze VHDL source code .
If multiple VHDL �le need to be analyzed, the bottom level module �le is expected to be analyzed before top
module �le:

> vhdlan -nc ../vhdl/ARITH_module.vhd

> vhdlan -nc ../vhdl/tb_multiplier.vhd

>vhdlan -nc ../vhdl/cfg_array_mult.vhd

please check and �x any error according to the the information given after execute this command

3) Execute the command below to compile and elaborate the design

>scs -nc cfg_array_mult

4) simulate the design

Two kinds of method can be used to simulate the design : File I/O� read stimulus from �le and write results into
�le. (In our example, we generate a vector �le named �expect_vector� , each cycle, the testbench read one row
of �expector_vector� and pass the values to the hardware multiplier as input. Then compare the hardware
output with the expected value in �expect_vector�, If any mismatch happens, write this cycle simulation
information to a �le named �error_vector� for debugging use) .

The second method is through observing the wave form of the simulation (following the commands below):

> scirocco &

Type in 'scsim -debug_all' to open the simulation in debug mode. (As seen in �gure )
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Figure 2: scsim window

In the VirSim window, click window -> Hierarchy

Figure 3: Hierarchy Window of Scsim
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In the VirSim-Interactive window, click Window -> Waveform , in order to add signals into the waveform ,
you need to select these signals in the Hierarchy window.For our tutorial design, in Hierarchy window, choose
�PT(31 downto 0) � and press the middle button of your mouse, drag this signal to the waveform region.
Similarly, add signals �XT(15 downto 0)� and �YT(15 downto 0)� to the waveform window.

Figure 4: Choose signals to be observed

In the VirSim-Interactive window, in �Simulator Control� area, you can set the Step Time ( we leave 20ns
as default ), and click �OK� . The Simulation begins , and you can observe the resulting waveform for your
debugging.

For behavior simulation, the major purpose is to verify the correctness of function. And from the wave form
below, we indeed observe that PT = XT × Y T ; thus verify the behavioral design.

Also, we can check the generated output �le �error_vector� for behavioral veri�cation.
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Figure 5: Simulation results

Behavior Simulation ( For Verilog input )

You are encouraged to use a third-party simulator during your code implementation stage. It is more con-
venient. Modelsim, ActiveHDL for examples. Also you can try it on the workstation with synopsys tools �
VCS.

Figure 6: A behavioral simulation by Modelsim

In �synopsys/sim� directory, following the commands as follows.

1) analyze the verilog �le and testbench

> vlogan ../verilog/ARITH_module.v

>vlogan +v2k ../verilog/Tb_multiplier.v

(note: our testbench is written in verilog IEEE2000 syntax, without �+v2k� ,vlogan command may fail due to
compatible issue)

2) compile/simulate the design
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• vcs +v2k ../verilog/Tb_multiplier.v ../verilog/ARITH_module.v (this compiles a simv �le)

• vcs +v2k -RI ../verilog/Tb_multiplier.v ../verilog/ARITH_module.v (this opens a GUI interface)

• In VirSim-Interactive window ; choose Window -> Hierarchy to get a hierarchy view of our design.
Choose Window -> Waveform to generate the waveform window.

Figure 7: VirSim hierarchy window

• Choose the signals we want to observe in the Hierarchy window ( pt[31:0], xt[15:0], yt[15:0] etc), hold
the middle button of the mouse , drag them into the waveform window

• In �VirSim- Interactive window� , in �Simulation Control� area, type in your desired step time, and press
OK. Then, you can observe the output waveforms
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Figure 8: Waveform window to be observed

Figure 9: Out put Waveforms

Synthesis with Synopsys Design Vision

Input Your Design

This section would guide you step by step to synthesize a 16-bit multiplier example. We would use Synopsys
Design Vision for this purpose.

• go to the syn library: cd ~/elec516-lab/synopsys/syn

• check out the there is a setup �le �.synopsys_dc_setup� : ls -a
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• In terminal : source ../../.cshrc_user (source the design vision)

• start design vision: design_vision &

For Linux workstations, the design_vision can be loaded correctly without any error or warning as �gure
below:

Figure 10: Design Vision Main Window

For UNIX SUN workstations, there may display some error messages of X-display as �gures below, normally,
it won't a�ect our synthesis process, we can ignore this compatible issue.

We may look at the main window of Design Vision to see a few of the program's features. In the top panel,
there are two panes. The left pane is a full Hierarchy pane; it will show the entire hierarchy of the current
design (as selected from the drop-down box in the upper control panel). The right panel is a context based
panel which will display contents based upon the selection in the drop down box at the top of the panel.

The bottom panel has three di�erent tabs: log, history and errors/warnings. The important thing to note
about this panel is that every command you perform will appear in this panel, allowing you to learn the
commands and create scripts of commands for future use. It is also the panel that you must monitor to
determine the source of errors and warnings, allowing you to �x the code or correctly determine if a warning
is expected.

• analyze the �le. Select File->Analyze and add the �le you want to analyze, in our design , choose
�elec516-lab/synopsys/vhdl/ARITH_module.vhd�.

After analyzing the �le, please check whether the compilation is sucessful.
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Figure 11: Errors due to compatible issue in Sun(eesu) workstation

Figure 13: After Analyze

Analyze is similar to compilation. It will check the syntax of each of the �les to verify correct use of the
language and that all code used is synthesizable.Note that for VHDL code, you must analyze in a speci�c
order because of some of the ordering requirements of VHDL. No particular order will be required when using
Verilog code with Design Vision. I recommend for the �rst time analyze your code, analyze one by one to see
the messages, after that, you can add it together1.

1Be careful not to include the testbench �le , this is not part of the design and can not be synthesized
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Figure 12: Analyze VHDL Code

Figure 14: Elaborate Design

• elaborate the analyzed code:

� File-> Elaborate;

� Change Library to �Work�; This is where you de�ned to store your intermediate results;

� Change Design to �Multiplier_15_0_1000�. This is your top module;

� Click �OK�;

The elaboration step may take several minutes. This step is similar to loading the design in Modelsim. The
design is checked to make sure that the code is synthesizable, the subdesigns connect correctly and that there
are no major errors in the implied circuit. (At the end of this step you may need to �x your code to remove
them by checking the output message: THIS IS A MUST). Alternatively, you can use File-> Read to perform
the function of analyze and elaborate.
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Figure 15: Message After Elaboration

Now that we have elaborated the design, we see some basic structure of the design in the main window of
Design Vision. See Figure.15. The left pane of the main window shows the full hierarchy of the design starting
from the design that is speci�ed as the top-level (from the drop-down box in the top tool panel). In the right
pane we can select what we see to help perform later tasks. By right clicking on a module, we may also choose
to see a schematic view from the right click menu. The schematic view may be useful, but requires a good
understanding of synthesis, as the module names may seem cryptic at �rst.

Design Check & Set Constraints

After you input all the design �les, it is sometimes necessary for you to link the design (In File->Link Design).
For sometime tools might no be able to correctly establish the interconnection between your di�erent modules.
When you �nish all these, you check your design for possible errors (Design->Check Design). Example check
results have warnings due to output connected to input ports directly (We can ignore this kind of warnings
since we dedicately connect them in our design) .

• Select Multiplier_15_0_1000 as your current design (this is the top design module) in the module
selection in the selection box right upper corner;

• Select Design->Check Design, and set the choice as shown in Figure.16;

• Check out the output messages;

You should perform frequency design check after each major operations which would a�ect the design logic.

Now you are going to set your design constraints to guide the mapping process. Common constraints are: clock
periods, timing/area/power constraints, input delay, output delay, false path, wire load, operating conditions,
fanout, etc.. (It's highly depends on the speci�cation of the design system )
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Figure 16: Check Design Box

Set Clock

Specify clock tells design vision the clock rate at which the design should be able to operate. This goal will
tell design vision to make sure to organize the modules such that calculations can all be performed within the
clock period. Various techniques such as logic duplication are used to achieve the goals. It is important to set
realistic goals for the clock rate so that design vision does not perform too much logic duplication to attempt
to reach the goal.

• Set Clock: If you have the clock pin in your design, then select this pin in port view, since in our
multiplier design,we don't have any clock pins, we need't select any pin ;

• Select Attributes->Specify Clock (see. Figure. 17);

• We create a clock name : vclk which means this is a virtual clock; Period is 0.5 here; feel free to try out
di�erent values to see how fast the system can run;

Figure 17: Specify Clock
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You will know if you have correctly selected Clk based upon if Clk shows up in the grayed out Port name box.
If that box is empty, be sure to close this dialog and make sure Clk is selected before opening this dialog. Since
a clock is a signal we don't want to optimize (prevents errors of the synthesizer disconnecting the signal), we
want to set the clock as a �don't touch� network. Select Don't touch network before clicking OK.

Set Input/Output Delay

Input delay tells design vision that a signal will always arrive at a certain time relative to the clock (after the
rising edge of the clock). When specifying delay, the delay should always be speci�ed relative to a clock so
that design vision may calculate delays correctly.

• Change the drop down box to Pins/Ports.

• Select->Ports/Pins->Input Ports to select all input pins

• Attributes->Operating Environment->Input Delay (If you did not select any signals, either the Input
Delay option in the menu would be grayed out, or there would be no entries in the Name �eld).

• Select vclk in the Relative to clock dropdown Specify 0.1 as the Minimum and Maximum delay This
means that input signals should be modeled so that they arrive 0.1nS after the edge of clk. Click OK

• Do the same for the output delay (This speci�es how long a signal takes to reach the chips output after
leaving your modules output after the clock edge.)

Figure 18: Set Input Delay

Wire Load

We must specify a wire load model so that design vision can estimate the delay that wires in the design have.
Each model is based upon a di�erent amount of resistance and capacitance for a certain amount of wire.
Design vision will use that amount to estimate how much delay is added to the circuit based on the length of
the wires and distance between the wires.
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• Attributes->Operating Environment->Wire Load;

• Select-> 5K_hvratio_1_1;

Figure 19: Wire Load

Design Constraints

This level of constraints allows us to set overall objectives of the design for design vision to attempt to reach.
We can set maximum values for area, power, fanout, and transition. Normally for this course we will only
set values for area and fanout, allowing power and transition to vary as design vision likes. This will speed
our synthesis time and will allow us to concentrate on the operation of the circuit rather than worrying about
power and other e�ects that require attention after full correctness is guaranteed.

In �Attributes > Optimization Constraints > Design constraints� we can set the optimization goal

Figure 20: Design Constraints
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Figure 21: Compile Design

Start Compile

Now we've setup all the constraints. We will start to compile the design (logic simpli�cation and technology
mapping) and hope that Design Vision would get a satisfactory design for all our constraints.

• Design->Compile Design

• Uncheck the exact map option (this would leads no logic optimization). See Figure. 21

After �nish, check out the output message. There're each optimization step output to tell you the current
trade-o�s between area and timings. Check if the design is satisfactory. Perform check design if necessary.

Figure 22: After compilation of the design

Then, you can save the mapped design. All the designs would be saved in ddc format. Later you can read in
the design where you left o�. Here, i want emphasis two things you need to save for use in back-end design.

• A verilog netlist for place & route and pre-layout simulation: In the hierarchical window, select the top
module, and then File->Save as, choose verilog format, name it as syn_netlist.v
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Figure 23: pre-layout simulation results

• A constraint �le for the constraints you set for synthesis. it would be used for back-end too. we name it
syn_netlist.sdc .

Report File

There're various report method you can use to check your design. The most important one is timing report
(like �Design > Report Design�).

Pre-Layout Simulation

Till now, you are required to perform Pre-Layout simulation to verify your function. The �le you needed is
syn_netlist.v and a library verilog �le called typical.v under �syn_sim� folder.

Using the similar method introduced in the � behavioral simulation for verilog � to do the pre-layout simulation

> cd elec516-lab/synopsys/syn_sim (where library �le typical.v and syn_netlist.v locates in)

>cp ../verilog/Tb_multiplier.v . (copy testbench to syn_sim folder)

>source /usr/eelocal/synopsys/vcs_mx-vy2006.06-sp1/.cshrc

>vlogan syn_netlist.v

>vlogan +v2k Tb_multiplier.v

>vcs -RI Tb_multiplier.v +v2k syn_netlist.v -v typical.v

Then,we enter into the GUI of the simulator. For how to choose signals for observation and the explanations
of the interface, you may refer to previous � behavioral simulation for verilog � section.
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Place & Route with Cadence Encounter

setup and start encounter

copy your generated netlist �le and constraint �le into encounter for back end use:

• cp syn_netlist.v ../../encounter

• source ../.cshrc_user

• check there're library �les under the �encounter� folder: �.lib� and �.lef� respectively

• start encounter: encounter (Make sure DO NOT type � & � after encounter )

(a) Basic Setting

(b) Power Setting & IPO Setting

Figure 24: Design Import

Load Design

• Design-> Design Import, set the Basic and Advanced Option as Figure. 24

19



• For future use, after you set up all the required �eld, you can save a con�g �le and next time directly
load it is ok

Connect Global Nets

• Click Floorplan->Connect Global Nets

• Following the setting listed in the table below and add the connects to the list

• Click Apply, and then Check. The Check command check for unconnected pins in your design. Verify
and �x if any warnings or errors appear in the encounter console.

Setting Setting1 Setting2 Setting3 Setting4

Connect Region Pins: VDD Tie High Pins: VSS Tie Low
Scope Region Apply All Apply All Apply All Apply All
To Global Net VDD VDD VSS VSS

Table 1: Global Nets Connections

Figure 25: Connect Global Nets

Floorplan

• Floorplan-> Specify Floorplan. See Figure.26 for the setting;

• Figure.27 shows the result �oorplan;
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Figure 26: Floorplan Setting

Figure 27: View After Floorplan
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Add Power Ring and Stripe

• Power->Power Planning->Add Rings (Figure. 28)

Figure 28: Add Ring Con�g

• Power->Power Planning->Add Stripe (Figure. 29)
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Figure 29: Add Stripe Con�g

After you add power ring and stripes, you can see now we have a primitive view in Figure.30 .

Figure 30: View after add power ring and stripes

Special Routing

• Route->Special Route; leave everything in default and ok

• Special Route would help you do the VDD/VSS connection.
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Figure 31: View after Special Routing

Place the Standard Cell

This step is to place the cell in your design into the �oorplan. The quality of placement would a�ect your
timing a lot.

• Place->Standard Cell and Blocks

• Un-check the Reorder Scan Connection

Figure 32: Placement Setting

After placement, switch your view into physical view. You can see how your cell is placed.
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Figure 33: Physical View after placement

Route the connection

• Route-> Nano Route->Route, leave everything is default

Here is what you get after routing:

Figure 34: View After Routing

Add Filler Cell

Filler Cell has no function and is added to �ll all the blank area without cells. The aim is to increase physical
stress.

• Place->Filler->Add...

• Select Filler Name and Add all available �llers (shown in Figure. )

• OK

25



Figure 35: Add Filler

Calculate Delay:

> Timing -> Extract RC... (leave everything as default and click OK)

> Timing -> Calculate Delay

The delay is extracted from the wire loading and save into an delay �le called �sdf � �le. We can use it to do
the Post-Layout simulation

Figure 36: Calculate Delay

Save the Final Netlist and layout �le

This netlist might be di�erent from the one you saved after synthesis. During P&R, some logic might be
optimized again for better timing. So you should use this netlist and sdf from last step to perform your
Post-Layout Simulation.

• Design->Save->Netlist, name the �le as your wish

• Design->Save Design to save the layout in enc �le format (the actual �le for fabrication is in gds format
you can also save it)

Post-simulation

The simulation can be done with the netlist from P&R, sdf �le from P&R which we have saved in the previous
step and standard cell library verilog �le (the same typical.v �le in pre-layout simulation). The sdf �le is
annotated to take account for the interconnection delay. you can refer to the appendix. for a reference to add
it in the testbench. (�$sdf_annotate� in the testbench) ; after adding sdf annotation in test bench, the post
layout simulation is similar to pre-layout simulation. (Note : Because we use the testbench which contains sdf
(timing information of layout) ,the results are more accurate).
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Appendix A

---------------------------------------------------------------------------------

// sample verilog testbench

`timescale 1ns / 1ps

module MyDesign_tb;

reg clk;

MyDesign uut ( // design ports );

always #50

clk = !clk;

initial begin

$sdf_annotate("./MyDesign.sdf", uut);

// uut is the name you instantiate your design in the testbench

// assume sdf in within the same folder of your simulation folder

end

initial begin

# 0 // Have your test bench here

# 10000000000

$finish;

end

endmodule

----------------------------------------------------------------------------------
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